summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-12-27 10:27:11 -0500
committerYixun Lan <dlan@gentoo.org>2024-12-29 00:00:08 +0000
commit8e6585ae24273d4235ea6caf71dae05fb92caa7a (patch)
tree3202d10ae525691b4c061dc751862874a81b3f67 /gui-libs
parentgui-libs/aquamarine: drop 0.4.1 (diff)
downloadgentoo-8e6585ae24273d4235ea6caf71dae05fb92caa7a.tar.gz
gentoo-8e6585ae24273d4235ea6caf71dae05fb92caa7a.tar.bz2
gentoo-8e6585ae24273d4235ea6caf71dae05fb92caa7a.zip
gui-libs/hyprcursor: backport fix for missing include
https://github.com/hyprwm/hyprcursor/pull/71 Closes: https://bugs.gentoo.org/946996 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/hyprcursor/files/0.1.10-fstream.patch39
-rw-r--r--gui-libs/hyprcursor/hyprcursor-0.1.10-r2.ebuild31
2 files changed, 70 insertions, 0 deletions
diff --git a/gui-libs/hyprcursor/files/0.1.10-fstream.patch b/gui-libs/hyprcursor/files/0.1.10-fstream.patch
new file mode 100644
index 000000000000..e46df53dc9b1
--- /dev/null
+++ b/gui-libs/hyprcursor/files/0.1.10-fstream.patch
@@ -0,0 +1,39 @@
+From 2b522b0350ea8a1878ded84d90e080691bdb8f0e Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Sat, 14 Dec 2024 11:24:52 +0100
+Subject: [PATCH] util: add missing header for libc++
+
+hyprcursor-util/src/main.cpp:260:19: error: implicit instantiation of undefined template 'std::basic_ofstream<char>'
+ 260 | std::ofstream manifest(out + "/manifest.hl", std::ios::trunc);
+ | ^
+/usr/include/c++/v1/__fwd/fstream.h:26:28: note: template is declared here
+ 26 | class _LIBCPP_TEMPLATE_VIS basic_ofstream;
+ | ^
+hyprcursor-util/src/main.cpp:292:41: error: implicit instantiation of undefined template 'std::basic_ifstream<char>'
+ 292 | std::ifstream xconfig("/tmp/hyprcursor-util/" + xcursor.path().stem().string() + ".conf");
+ | ^
+/usr/include/c++/v1/__fwd/fstream.h:24:28: note: template is declared here
+ 24 | class _LIBCPP_TEMPLATE_VIS basic_ifstream;
+ | ^
+hyprcursor-util/src/main.cpp:370:23: error: implicit instantiation of undefined template 'std::basic_ofstream<char>'
+ 370 | std::ofstream meta(CURSORDIR + "/meta.hl", std::ios::trunc);
+ | ^
+/usr/include/c++/v1/__fwd/fstream.h:26:28: note: template is declared here
+ 26 | class _LIBCPP_TEMPLATE_VIS basic_ofstream;
+ | ^
+---
+ hyprcursor-util/src/main.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hyprcursor-util/src/main.cpp b/hyprcursor-util/src/main.cpp
+index b6235cb..97e6573 100644
+--- a/hyprcursor-util/src/main.cpp
++++ b/hyprcursor-util/src/main.cpp
+@@ -2,6 +2,7 @@
+ #include <zip.h>
+ #include <optional>
+ #include <filesystem>
++#include <fstream>
+ #include <array>
+ #include <format>
+ #include <algorithm>
diff --git a/gui-libs/hyprcursor/hyprcursor-0.1.10-r2.ebuild b/gui-libs/hyprcursor/hyprcursor-0.1.10-r2.ebuild
new file mode 100644
index 000000000000..0c83215b1f8d
--- /dev/null
+++ b/gui-libs/hyprcursor/hyprcursor-0.1.10-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The hyprland cursor format, library and utilities"
+HOMEPAGE="https://github.com/hyprwm/hyprcursor"
+SRC_URI="https://github.com/hyprwm/hyprcursor/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
+
+RDEPEND="
+ dev-cpp/tomlplusplus
+ >=dev-libs/hyprlang-0.4.2
+ dev-libs/libzip
+ gnome-base/librsvg:2
+ x11-libs/cairo
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.1.10-llvm-fix.patch
+ "${FILESDIR}"/0.1.10-fstream.patch
+)