summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-15 21:25:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-15 22:07:07 +0200
commit6f5921f45fb81089e2360d7b8753b8803e79a340 (patch)
treeae05277788c17891b03a8542d77ca2547ef1d7c1 /kde-apps/ark
parentapp-editors/ghostwriter: 23.08.1 version bump (diff)
downloadgentoo-6f5921f45fb81089e2360d7b8753b8803e79a340.tar.gz
gentoo-6f5921f45fb81089e2360d7b8753b8803e79a340.tar.bz2
gentoo-6f5921f45fb81089e2360d7b8753b8803e79a340.zip
kde-apps/ark: 23.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-23.08.1.ebuild83
-rw-r--r--kde-apps/ark/files/ark-23.08.1-cmake.patch40
3 files changed, 124 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 1c1cf5da6c38..353e1af664fe 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-23.04.3.tar.xz 3010636 BLAKE2B 93600fb21940839bafd25aabfb1ff346088b0bef7c49e1d73cc6b3e17d073dfca924caa747d2c0f3c70ccd63569aebc3d8a6d137c7503c9a17a1af1ab833b4b9 SHA512 6ca740fef459232cf7ff19d76b2ddcb080b8c9b34a0c718dae0875253417a6f3f8f9c4a7bd2bc5002ae06bb41eef7f958a40f0d54896680e82879ef0f1cbed10
DIST ark-23.08.0.tar.xz 3016056 BLAKE2B d3ec1b07951f4aff70383d7d0748939e94bb4e26a09b16156613996c24f20a8d19623cd308b561c9f1bca71020e1435783fff8784b30d9ccfb55be3b5f67451b SHA512 84fc163e2f5c1b41d72978bb0f8a3e12aab68d681c7b2224dbf3b37bffd3c61814f54d1f647ec3aec34a2024275e7258f320fa2e692f2de08108999a2140d578
+DIST ark-23.08.1.tar.xz 3016220 BLAKE2B 7bc22a83b9f0bf3a426a3a9a0d6eea9f053c808e475cd5c777144b6229317ee7415f0469e758216b7f425588503e30426bd146f48656faccfc785ffdabb1c387 SHA512 fd2e99695e1dbcab2118ab0d38595852a2afd4490d07322fc5558eb3a4134d21206477675cbe8658009092faffc94e65953c138a929df1be682d80f8106c0b8a
diff --git a/kde-apps/ark/ark-23.08.1.ebuild b/kde-apps/ark/ark-23.08.1.ebuild
new file mode 100644
index 000000000000..890af802575e
--- /dev/null
+++ b/kde-apps/ark/ark-23.08.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="optional"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org optfeature
+
+DESCRIPTION="File archiver by KDE"
+HOMEPAGE="https://apps.kde.org/ark/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="zip"
+
+RDEPEND="
+ >=app-arch/libarchive-3.5.3:=[bzip2,lzma]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.6.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ test? ( >=dev-libs/libzip-1.6.0:= )
+"
+# app-arch/rar is binary only
+BDEPEND="
+ sys-devel/gettext
+ elibc_glibc? ( test? ( amd64? ( app-arch/rar ) x86? ( app-arch/rar ) ) )
+"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package zip LibZip)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # bug 822177: kerfuffle-addtoarchivetest: may segfault or hang indefinitely
+ # bug 827840: plugins-clirartest: continuously broken with translations installed
+ -E "(kerfuffle-addtoarchivetest|plugins-clirartest)"
+ )
+
+ ecm_src_test
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "rar archive creation/extraction" "app-arch/rar"
+ optfeature "rar archive extraction only" "app-arch/unar" "app-arch/unrar"
+ optfeature "7-Zip archive support" "app-arch/p7zip"
+ optfeature "lrz archive support" "app-arch/lrzip"
+ optfeature "Markdown support in text previews" "kde-misc/markdownpart:${SLOT}"
+ fi
+ ecm_pkg_postinst
+}
diff --git a/kde-apps/ark/files/ark-23.08.1-cmake.patch b/kde-apps/ark/files/ark-23.08.1-cmake.patch
new file mode 100644
index 000000000000..5bdf0af81435
--- /dev/null
+++ b/kde-apps/ark/files/ark-23.08.1-cmake.patch
@@ -0,0 +1,40 @@
+From 149271d3e341eea531405191ff1002fda86fdf84 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 14 Sep 2023 15:53:36 +0200
+Subject: [PATCH] Drop unused ItemModels dependency
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+(cherry picked from commit 9343567be9f895cbe5e290f88c9a933db34cdd95)
+---
+ CMakeLists.txt | 1 -
+ part/CMakeLists.txt | 2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 510adbc5..764cce99 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -40,7 +40,6 @@ find_package(KF${QT_MAJOR_VERSION} ${KF_MIN_VERSION} REQUIRED COMPONENTS Config
+ DBusAddons
+ DocTools
+ I18n
+- ItemModels
+ KIO
+ Service
+ Parts
+diff --git a/part/CMakeLists.txt b/part/CMakeLists.txt
+index c4c96972..d760f78a 100644
+--- a/part/CMakeLists.txt
++++ b/part/CMakeLists.txt
+@@ -26,7 +26,7 @@ ki18n_wrap_ui(arkpart
+ jobtracker.ui)
+
+
+-target_link_libraries(arkpart kerfuffle KF${QT_MAJOR_VERSION}::Parts KF${QT_MAJOR_VERSION}::KIOFileWidgets KF${QT_MAJOR_VERSION}::ItemModels)
++target_link_libraries(arkpart kerfuffle KF${QT_MAJOR_VERSION}::Parts KF${QT_MAJOR_VERSION}::KIOFileWidgets)
+
+ if(QT_MAJOR_VERSION STREQUAL "5")
+ configure_file(
+--
+2.42.0
+