summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-07 17:11:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-07 20:06:09 +0100
commit4f616baec4b1dd75d62fa483a3dae26117a37b2c (patch)
tree53184b8cb5e2c8de34b70e4d27aaa930dc111076 /kde-apps/dolphin-plugins-dropbox
parentmedia-sound/krecorder: 24.08.3 version bump (diff)
downloadgentoo-4f616baec4b1dd75d62fa483a3dae26117a37b2c.tar.gz
gentoo-4f616baec4b1dd75d62fa483a3dae26117a37b2c.tar.bz2
gentoo-4f616baec4b1dd75d62fa483a3dae26117a37b2c.zip
kde-apps/dolphin-plugins-dropbox: 24.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index e3115a6647aa..3982f57c3abe 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-24.08.1.tar.xz 317532 BLAKE2B 1f8bbcbcf79ca80e0744cbf5a1ecc4507d1e222c6ef179e01aac62361625d550702d014e28bb409d87cafad5bd57ae5d25bbc289177685681e84aa4261ac4b17 SHA512 d123197d4669611f0d12ad128967686d11b865865472028e60916e85bc4f0a5159e023a2784cba04e069ea5dbd9fd0801617b73e4033cffe1f6d815895aac59c
DIST dolphin-plugins-24.08.2.tar.xz 317744 BLAKE2B 5ea4755bee6d5ec3a3dbb30e1afe290818bdb57e14421fbb9a907f8f791e6001eef8cf134ec3d9415ca43824153bf55096f8f3e1ee2434a58795da979957a2db SHA512 c89a7a6d9f1a2d567522e126e25b52290205f96166ceb9b95c8aa0fbcf28424891ed1e60a1cdd4b158fd4ed48bb3b7a6bcdb6c79fe712b1cbdeb13c0c275a1f5
+DIST dolphin-plugins-24.08.3.tar.xz 317540 BLAKE2B 54fa2e13be2cceb53b12b1edb2d6d7c1793f6ba2bbec67e9e00121b33683aa6bd4895392cbdf5aa7627958c6323984ae3db8b5bbf6b14faba86b13181e0a2614 SHA512 05da7ac7b3ebe085cf0808d8e1eba49372bfeb1488800f40c1d0b9025e743efede1200095a1e660c1d538b2cc1b19f0f717f3d0723043517859f5c2015f961ce
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.3.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.3.ebuild
new file mode 100644
index 000000000000..9f135973ebef
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/dolphin-plugins-common-${PV}
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}