summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/kdepim-addons
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kdepim-addons')
-rw-r--r--kde-apps/kdepim-addons/Manifest1
-rw-r--r--kde-apps/kdepim-addons/kdepim-addons-18.12.1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/kde-apps/kdepim-addons/Manifest b/kde-apps/kdepim-addons/Manifest
index dd0871162588..2ca86b87b136 100644
--- a/kde-apps/kdepim-addons/Manifest
+++ b/kde-apps/kdepim-addons/Manifest
@@ -1,2 +1,3 @@
DIST kdepim-addons-18.08.3.tar.xz 2134684 BLAKE2B cf311193dd1e100fd4c3c08926be0b8102795f7e7475b3610be4dc60e4071a5286bbfffcd7928edd5ae3f779c7266e9efe08664abea153bd95c8840c05240f92 SHA512 9d9ec5c0c51f14bc7936e40b8d67f67120e4d458d1b226dfcfc08b6aa28a30255300a83758c3af7b1e68e7f755fc198208402027303f4451c054dba4c7ef8f82
DIST kdepim-addons-18.12.0.tar.xz 2038112 BLAKE2B ceb133bdeeca82980fd2c92da0edeade5dcbef20ec632bc2208e2cba57bfd136891f833e8471372977fb3927c554eddaa608f2b71f47878f0da5048a8949c861 SHA512 b23e9abbd3916be36bb50fbbed4972b29712d9e26c46b65328538caf44e96dfe950c591f3a4854b048681e3c3d239cf5965c6e31394fd8c6a6a1e132b2d5b8e0
+DIST kdepim-addons-18.12.1.tar.xz 2039288 BLAKE2B 46723c7936fb8b9fff5329157b308fe117ce91a26fab8391be6bd5b1efb49546280ef5ec6549bafe98c181eff105cb2ceb2f7249367ac6d071b3f261f301ceee SHA512 f731a24509223770cccc3266d2c2b9b78b40aa5faafe2365c58cb6050051d379da6fbbcf8091121c0083cc959c5f168a0dc3678cdf1c42d0ce1fbf1a20a06719
diff --git a/kde-apps/kdepim-addons/kdepim-addons-18.12.1.ebuild b/kde-apps/kdepim-addons/kdepim-addons-18.12.1.ebuild
new file mode 100644
index 000000000000..6fca357d3d7f
--- /dev/null
+++ b/kde-apps/kdepim-addons/kdepim-addons-18.12.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_EXAMPLES="true"
+KDE_TEST="forceoptional-recursive"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plugins for KDE Personal Information Management Suite"
+HOMEPAGE="https://www.kde.org/applications/office/kontact/"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="importwizard markdown"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep prison)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep eventviews)
+ $(add_kdeapps_dep grantleetheme)
+ $(add_kdeapps_dep incidenceeditor)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdepim-apps-libs)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kitinerary)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kpkpass)
+ $(add_kdeapps_dep libkdepim)
+ $(add_kdeapps_dep libkleo)
+ $(add_kdeapps_dep libksieve)
+ $(add_kdeapps_dep libktnef)
+ $(add_kdeapps_dep mailcommon)
+ $(add_kdeapps_dep messagelib)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ importwizard? ( $(add_kdeapps_dep akonadi-import-wizard) )
+ markdown? ( app-text/discount )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-crypt/gpgme-1.7.1[cxx,qt5]
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kaddressbook:4
+ !kde-apps/kdepim-l10n
+ !kde-apps/kmail:4
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDEPIMADDONS_BUILD_EXAMPLES=$(usex examples)
+ $(cmake-utils_use_find_package importwizard KPimImportWizard)
+ $(cmake-utils_use_find_package markdown Discount)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ ${KDE_BUILD_TYPE} = live ]] && ! has_version "kde-misc/kregexpeditor" ; then
+ elog "${PN} Sieve editor plugin can make use of kde-misc/kregexpeditor if installed."
+ fi
+}