summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-12-27 13:24:25 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-12-30 03:04:31 +1100
commit0d5c6a9567e463fb1a2901e7b91accf67c041bd7 (patch)
treed8721fd6b77608f6934e169cc736f03b02e9a959 /kde-apps/kdepim-runtime
parentmedia-gfx/digikam: Fix build w/ media-libs/lensfun-0.3.2, bug 566624 (diff)
downloadgentoo-0d5c6a9567e463fb1a2901e7b91accf67c041bd7.tar.gz
gentoo-0d5c6a9567e463fb1a2901e7b91accf67c041bd7.tar.bz2
gentoo-0d5c6a9567e463fb1a2901e7b91accf67c041bd7.zip
kde-base: pkgmove KDE PIM to kde-apps/
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/Manifest2
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-4.14.10.ebuild43
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-4.14.8.ebuild43
-rw-r--r--kde-apps/kdepim-runtime/metadata.xml9
4 files changed, 97 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/Manifest b/kde-apps/kdepim-runtime/Manifest
new file mode 100644
index 000000000000..ea60e1a8045d
--- /dev/null
+++ b/kde-apps/kdepim-runtime/Manifest
@@ -0,0 +1,2 @@
+DIST kdepim-runtime-4.14.10.tar.xz 1175432 SHA256 d68d1e3278646c3e82c7913dd443b5e10c887fb983fad7d24b26916ed4afcd52 SHA512 599cf08ee7c4bfcc2dcde7d146c5c889663a463e59e4e4773e6b1cee909d02914fce414afe473a127d484b5daa2fa9332dcef8092c3b953cdbebc87663e70577 WHIRLPOOL c40c44f266716f7136c253904e7ee65c6e40de40df458608cc4a1f7e02ada5b17febe4611e7693ef48c63201577ca21866b82005849bdd2409dfd1415d9ba251
+DIST kdepim-runtime-4.14.8.tar.xz 1173688 SHA256 1f4c82629947d7f1f796f1faf6333c861f908f1a02d9ae26a2adcfa698aa34b1 SHA512 378d59077493b9483ced85b7dd035ac792c1f5351f85a42459516f86028c8372f6304e6d36d6c4d33bb299847cc7650299e59afd7b100e755702943841f7f013 WHIRLPOOL e6554d278461e4324d28890c39ed083369eb89db64be9ac7270510e0e0f0c82a24ac7fd49a62567dae2168611a409f990bdd504e574493b90761378f3c1e7798
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-4.14.10.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-4.14.10.ebuild
new file mode 100644
index 000000000000..4edf1c7a2591
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-4.14.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+EGIT_BRANCH="KDE/4.14"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ >=app-office/akonadi-server-1.12.90
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdeapps_dep kdepimlibs 'akonadi(+)')
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi:4 )
+ google? ( >=net-libs/libkgapi-2.0:4 )
+ kolab? ( >=net-libs/libkolab-0.5 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-4.14.8.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-4.14.8.ebuild
new file mode 100644
index 000000000000..94d866e18852
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-4.14.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+EGIT_BRANCH="KDE/4.14"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ >=app-office/akonadi-server-1.12.90
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdeapps_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi:4 )
+ google? ( >=net-libs/libkgapi-2.0:4 )
+ kolab? ( >=net-libs/libkolab-0.5 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kdepim-runtime/metadata.xml b/kde-apps/kdepim-runtime/metadata.xml
new file mode 100644
index 000000000000..90dda7f2246f
--- /dev/null
+++ b/kde-apps/kdepim-runtime/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="facebook">Facebook service integration via <pkg>net-libs/libkfbapi</pkg></flag>
+ <flag name="google">Google service integration via <pkg>net-libs/libkgapi</pkg></flag>
+</use>
+</pkgmetadata>