summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:22:48 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:00 -0400
commit9e5a888796306a04ee632220be918026b1a51e1c (patch)
tree60db90b1c5b6e4afc8d48676c18f797b72fbe8b1 /mail-filter/dcc
parentgames-board/xgammon: pass -std=gnu89 (diff)
downloadgentoo-9e5a888796306a04ee632220be918026b1a51e1c.tar.gz
gentoo-9e5a888796306a04ee632220be918026b1a51e1c.tar.bz2
gentoo-9e5a888796306a04ee632220be918026b1a51e1c.zip
mail-filter/dcc: fix for -std=c2x early
Only two functions were using K&R style and no other issues, so patching rather than pass -std=gnu89 (since not going to use it, also drop unused flag-o-matic while here). (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'mail-filter/dcc')
-rw-r--r--mail-filter/dcc/dcc-1.3.158-r2.ebuild3
-rw-r--r--mail-filter/dcc/files/dcc-1.3.158-c2x.patch21
2 files changed, 23 insertions, 1 deletions
diff --git a/mail-filter/dcc/dcc-1.3.158-r2.ebuild b/mail-filter/dcc/dcc-1.3.158-r2.ebuild
index 7aac567ecd12..6c09223f5624 100644
--- a/mail-filter/dcc/dcc-1.3.158-r2.ebuild
+++ b/mail-filter/dcc/dcc-1.3.158-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Distributed Checksum Clearinghouse"
HOMEPAGE="https://www.rhyolite.com/dcc/"
@@ -36,6 +36,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.3.140-freebsd.patch
"${FILESDIR}"/${P}-fno-common.patch
"${FILESDIR}"/${P}-clang16.patch
+ "${FILESDIR}"/${P}-c2x.patch
)
src_configure() {
diff --git a/mail-filter/dcc/files/dcc-1.3.158-c2x.patch b/mail-filter/dcc/files/dcc-1.3.158-c2x.patch
new file mode 100644
index 000000000000..79b70f300f8f
--- /dev/null
+++ b/mail-filter/dcc/files/dcc-1.3.158-c2x.patch
@@ -0,0 +1,21 @@
+This is the only K&R-style functions in the source, incompatible with C2x.
+--- a/dcclib/inet_ntop.c
++++ b/dcclib/inet_ntop.c
+@@ -88,7 +88,3 @@
+ */
+-static const char *
+-inet_ntop4(src, dst, size)
+- const u_char *src;
+- char *dst;
+- size_t size;
++static const char *inet_ntop4(const u_char *src, char *dst, size_t size)
+ {
+@@ -115,7 +111,3 @@
+ */
+-static const char *
+-inet_ntop6(src, dst, size)
+- const u_char *src;
+- char *dst;
+- size_t size;
++static const char *inet_ntop6(const u_char *src, char *dst, size_t size)
+ {