summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-26 17:59:12 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-26 19:22:50 +0200
commitfeeb7ba2e0158a4d6a52781c4dd634f9ef33ee0b (patch)
treeb695fcbf0cecc611eec146b6ff32dbc03baf892d /media-gfx/graphicsmagick
parentsys-apps/systemd: restore static-libs support (diff)
downloadgentoo-feeb7ba2e0158a4d6a52781c4dd634f9ef33ee0b.tar.gz
gentoo-feeb7ba2e0158a4d6a52781c4dd634f9ef33ee0b.tar.bz2
gentoo-feeb7ba2e0158a4d6a52781c4dd634f9ef33ee0b.zip
media-gfx/graphicsmagick: bump to v1.3.33
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-gfx/graphicsmagick')
-rw-r--r--media-gfx/graphicsmagick/Manifest1
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/media-gfx/graphicsmagick/Manifest b/media-gfx/graphicsmagick/Manifest
index f8413f51295f..abc5659d8a30 100644
--- a/media-gfx/graphicsmagick/Manifest
+++ b/media-gfx/graphicsmagick/Manifest
@@ -1,2 +1,3 @@
DIST GraphicsMagick-1.3.30.tar.xz 5496116 BLAKE2B 408f68334b290ae30d06e4b0efa6e11e89ffa9c00781e2f0ceb25cd6fc308f1be86b5ed9bd52f594e1abd3351f1b7dbfb12e87117ba85f4b4c01d07d7480772a SHA512 4f04245b8abef85de96a1527ad4adc1fadea144a1917db3ea21632a9fe732bdaa7021ffdbbeb7c2ead814ca7b6a14e81bb68a962bbfb64fa6809a235f1b0be5c
DIST GraphicsMagick-1.3.32.tar.xz 5535224 BLAKE2B 96fd7bfe62b4b1b25f9ffc0ff8e2ac023f0528b9af857fc27a5a9cd1123eeb6533b868c7bad8dca5b58e114a674dda009a62904df64622d7b5f3c0d72156283d SHA512 f84cdb9318962aed1dc25d70db4d0ca102e4f88748f468f8a56b77d228fd315b772afa48e90a396d32e8226eba9105717bcb94166bbe43723afeec58ead53e09
+DIST GraphicsMagick-1.3.33.tar.xz 5558348 BLAKE2B 9c3747ee63d94bc6d16c06c04c7fad2ca93e849df7ae4391523b416111b5569c7493226f6b967a5ff80e0ff2ccbe7f6de5a7223e935024fd66a96be401fdf26b SHA512 8afeb461d1a9dab9b88b9bc7c2d50b5c409463b369e6b0ba7ee39b0ece32da9393d7a5a4d18faf8f72a529346a3477bae61b802bac2af81aeae79d95c9d6cd13
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild
new file mode 100644
index 000000000000..b7015389b707
--- /dev/null
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+MY_P=${P/graphicsm/GraphicsM}
+
+DESCRIPTION="Collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.graphicsmagick.org/"
+LICENSE="MIT"
+SLOT="0/${PV%.*}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+IUSE="bzip2 cxx debug fpx imagemagick jbig jpeg lcms lzma modules openmp
+ perl png postscript q16 q32 static-libs svg threads tiff truetype
+ webp wmf X zlib"
+
+RDEPEND="dev-libs/libltdl:0
+ bzip2? ( app-arch/bzip2 )
+ fpx? ( media-libs/libfpx )
+ imagemagick? ( !media-gfx/imagemagick )
+ jbig? ( media-libs/jbigkit )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng:0= )
+ postscript? ( app-text/ghostscript-gpl )
+ svg? ( dev-libs/libxml2 )
+ tiff? ( media-libs/tiff:0 )
+ truetype? (
+ media-fonts/urw-fonts
+ >=media-libs/freetype-2
+ )
+ webp? ( media-libs/libwebp:= )
+ wmf? ( media-libs/libwmf )
+ X? (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.19-flags.patch
+ "${FILESDIR}"/${PN}-1.3.19-perl.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local depth=8
+ use q16 && depth=16
+ use q32 && depth=32
+
+ local openmp=disable
+ if use openmp && tc-has-openmp; then
+ openmp=enable
+ fi
+
+ local myeconfargs=(
+ --${openmp}-openmp
+ --enable-largefile
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable debug prof)
+ $(use_enable debug gcov)
+ $(use_enable imagemagick magick-compat)
+ $(use_with threads)
+ $(use_with modules)
+ --with-quantum-depth=${depth}
+ --without-frozenpaths
+ $(use_with cxx magick-plus-plus)
+ $(use_with perl)
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_with bzip2 bzlib)
+ $(use_with postscript dps)
+ $(use_with fpx)
+ $(use_with jbig)
+ $(use_with webp)
+ $(use_with jpeg)
+ --without-jp2
+ $(use_with lcms lcms2)
+ $(use_with lzma)
+ $(use_with png)
+ $(use_with tiff)
+ $(use_with truetype ttf)
+ $(use_with wmf)
+ --with-fontpath="${EPREFIX}"/usr/share/fonts
+ --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+ --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
+ $(use_with svg xml)
+ $(use_with zlib)
+ $(use_with X x)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use perl && emake perl-build
+}
+
+src_test() {
+ unset DISPLAY # some perl tests fail when DISPLAY is set
+ default
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ emake -C PerlMagick DESTDIR="${D}" install
+ find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
+ find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
+ fi
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
+}