summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-25 10:00:48 +0000
committerSam James <sam@gentoo.org>2024-03-25 10:01:25 +0000
commitba85df67ca35c280d8dde86097479918f81afa13 (patch)
treefc46aec31f64a89c7552a6c4751eb38e7e00c877 /media-gfx/graphite2
parentsys-apps/syd: add 3.15.6 (diff)
downloadgentoo-ba85df67ca35c280d8dde86097479918f81afa13.tar.gz
gentoo-ba85df67ca35c280d8dde86097479918f81afa13.tar.bz2
gentoo-ba85df67ca35c280d8dde86097479918f81afa13.zip
media-gfx/graphite2: skip known-failing test for GCC 13, run tests for multilib
The multilib tests work fine, not sure what that was about. Skip a known-failing test (it's already reported upstream). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/graphite2')
-rw-r--r--media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild b/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild
index 580df138e20e..9439faed0363 100644
--- a/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild
+++ b/media-gfx/graphite2/graphite2-1.3.14_p20210810-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
COMMIT=80c52493ef42e6fe605a69dcddd2a691cd8a1380
GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit flag-o-matic perl-module python-any-r1 cmake-multilib
DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
@@ -101,11 +101,12 @@ src_compile() {
}
multilib_src_test() {
- if multilib_is_native_abi; then
- cmake_src_test
- else
- einfo "Cannot test since python is not multilib."
- fi
+ CMAKE_SKIP_TESTS=(
+ # https://github.com/silnrsi/graphite/pull/74
+ nametabletest
+ )
+
+ cmake_src_test
}
src_test() {