summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/ipe/ipe-7.1.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/ipe/ipe-7.1.3.ebuild')
-rw-r--r--media-gfx/ipe/ipe-7.1.3.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/ipe/ipe-7.1.3.ebuild b/media-gfx/ipe/ipe-7.1.3.ebuild
new file mode 100644
index 000000000000..526bb3ef62c3
--- /dev/null
+++ b/media-gfx/ipe/ipe-7.1.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
+HOMEPAGE="http://ipe7.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ipe7/${PN}/7.1.0/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/texlive-core
+ dev-lang/lua
+ media-libs/freetype:2
+ x11-libs/cairo
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${P}/src"
+
+search_urw_fonts() {
+ # colon-separated list of paths
+ local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"
+ # according to TeX directory structure
+ local urwdir=fonts/type1/urw
+ # add colon as field separator
+ local IFS="${IFS}:" dir
+ for dir in ${texmfdist}; do
+ if [[ -d ${dir}/${urwdir} ]]; then
+ URWFONTDIR="${dir}/${urwdir}"
+ return 0
+ fi
+ done
+ return 1
+}
+
+pkg_setup() {
+ if search_urw_fonts; then
+ einfo "URW fonts found in ${URWFONTDIR}"
+ else
+ ewarn "Could not find directory containing URW fonts"
+ ewarn "Ipe will not function properly without them."
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/fpic/fPIC/' \
+ -e 's/moc-qt4/moc/' \
+ -e "s:\$(IPEPREFIX)/lib:\$(IPEPREFIX)/$(get_libdir):g" \
+ config.mak || die
+ sed -i -e 's/install -s/install/' common.mak || die
+
+ epatch "${FILESDIR}"/${P}-gold.patch
+}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ IPEPREFIX="${EPREFIX}/usr" \
+ IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ emake install \
+ IPEPREFIX="${EPREFIX}/usr" \
+ IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
+ INSTALL_ROOT="${ED}"
+ dodoc ../{news,readme}.txt
+ doicon ipe/icons/ipe.png
+ make_desktop_entry ipe Ipe ipe
+}