summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-12 02:59:07 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-12 04:59:38 -0400
commit9c5400955275cd01f1bb57c3543f53732bd6305b (patch)
treedb158f58f60c7c4d294b01cac5e91ededd0bf807 /media-gfx/ueberzugpp
parentmedia-gfx/ueberzugpp: new package, add 2.8.0 (diff)
downloadgentoo-9c5400955275cd01f1bb57c3543f53732bd6305b.tar.gz
gentoo-9c5400955275cd01f1bb57c3543f53732bd6305b.tar.bz2
gentoo-9c5400955275cd01f1bb57c3543f53732bd6305b.zip
media-gfx/ueberzugpp: add 2.8.1 (unkeyworded)
Initially tried to add this version, but has some code refactoring which seems(?) to break things -- e.g. with ytfzf thumbnails are too small (likely confusing terminal cols/rows with pixels), and kitty output just segfaults. Barely came out (few hours ago), so going to give it some time to see what's up. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/ueberzugpp')
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.8.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index 6ada33d3f14a..952bf5556761 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1 +1,2 @@
DIST ueberzugpp-2.8.0.tar.gz 38768 BLAKE2B 80c879196339e3ce8fc5aeb2a87df8d3785021f72e5c0e47c55026d5cefc8cd3caa2174fea8413c642f54190970480488a6ec09d93e765b59dcf6616369dfbb7 SHA512 a5fceec97300cc3ada6c087fadc3b2d70f574207c5fd3f682c1a56b877c2b76ff40abe0ae76767e22ae82742be2bedee782e0ec86d200d28a15061bc1b4c2696
+DIST ueberzugpp-2.8.1.tar.gz 41270 BLAKE2B 249c10aafe33d83ceedd9632d2518fdbf724e07f49539704a6dd2ef0c3c942017c64b9ade3142cefa45ac19299176cd0a91b5a49f7467e2b04466e901b2a5c73 SHA512 d7f7e08a713c7e882f6de37f0d39913fdd6d3ca2c40e4520bac56a01cfcdbf6cc7095128602f15ec95b824b240e91ad231ac85fe651216708ba378ae5eeff7a1
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.8.1.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.8.1.ebuild
new file mode 100644
index 000000000000..a4af8962ba58
--- /dev/null
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Drop in replacement for ueberzug written in C++"
+HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
+SRC_URI="https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+# unkeyworded for testing, contains code refactoring and seem to have issues
+KEYWORDS=""
+IUSE="X opencv"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ media-libs/libsixel
+ media-libs/vips:=
+ net-libs/zeromq:=
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ )
+ opencv? ( media-libs/opencv:= )
+ !media-gfx/ueberzug"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cli11
+ dev-cpp/nlohmann_json
+ net-libs/cppzmq
+ X? ( x11-base/xorg-proto )"
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release # install target wants this
+
+ local mycmakeargs=(
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_TURBOBASE64=no # not packaged
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # not handled by cmake, but upstream creates the pp symlink in their
+ # self-maintained AUR package and some scripts like ytfzf look for it
+ dosym ueberzug /usr/bin/${PN}
+}