summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-15 10:45:42 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-15 10:45:55 +0200
commit086cdb657c4cc10d9006e6e0a52414993faa42d9 (patch)
tree55ca0493e34e6990259bf9d5ccf88609b80b1bd2 /media-gfx/xfig
parentmedia-gfx/fig2dev: new package, add 3.2.9 (diff)
downloadgentoo-086cdb657c4cc10d9006e6e0a52414993faa42d9.tar.gz
gentoo-086cdb657c4cc10d9006e6e0a52414993faa42d9.tar.bz2
gentoo-086cdb657c4cc10d9006e6e0a52414993faa42d9.zip
media-gfx/xfig: add 3.2.9
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'media-gfx/xfig')
-rw-r--r--media-gfx/xfig/Manifest1
-rw-r--r--media-gfx/xfig/files/xfig-3.2.9-app-defaults.patch12
-rw-r--r--media-gfx/xfig/xfig-3.2.9.ebuild51
3 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/xfig/Manifest b/media-gfx/xfig/Manifest
index eaa8f0ea2b77..eedea84da010 100644
--- a/media-gfx/xfig/Manifest
+++ b/media-gfx/xfig/Manifest
@@ -1 +1,2 @@
DIST xfig-3.2.8b.tar.xz 5382524 BLAKE2B 94963d165664c6451776fcbc3e332a7933c00d4b43e3d4196f15883a9873171f7a0791e6fa41cbb6e8d07958f9ddcceb9578a62a9893cf2f436c07dcbe3e7f37 SHA512 5cc5e61977f97956baca77bf4bce09d0f47ea6fafb10055d0523f7cccd72d7af80e706daa62ae16df3fc54338b4f6cd4a6b71dc460311e65be749ec84fa662b3
+DIST xfig-3.2.9.tar.xz 5368544 BLAKE2B 6fd04d7238453d304a5e9624524f1e3674fe21ea3485d0925fa430a6312b61019a54397301cd7773565035cd3aee7fa130ed2459187241a778c0d44759c57d45 SHA512 c5e797b394740761a24e6e5e83d025dd78a11ad7d12662728c708218d7131d9077d9ed0c09023134ed9d709c58f52f5c9182e5b50e540b1876be4c359d79a60e
diff --git a/media-gfx/xfig/files/xfig-3.2.9-app-defaults.patch b/media-gfx/xfig/files/xfig-3.2.9-app-defaults.patch
new file mode 100644
index 000000000000..09c61453f679
--- /dev/null
+++ b/media-gfx/xfig/files/xfig-3.2.9-app-defaults.patch
@@ -0,0 +1,12 @@
+diff -ruN xfig-3.2.8b.orig/app-defaults/Fig xfig-3.2.6a/app-defaults/Fig
+--- xfig-3.2.8b.orig/app-defaults/Fig 2017-01-10 00:27:39.000000000 +0100
++++ xfig-3.2.8b/app-defaults/Fig 2017-03-24 16:22:14.702253419 +0100
+@@ -10,4 +10,8 @@
+
++! If the following resource is set to false, xfig will use metric units
++! by default.
++Fig.inches: false
++
+ ! The following fixes a problem that some window managers have
+ ! with xfig continually resizing itself
+
diff --git a/media-gfx/xfig/xfig-3.2.9.ebuild b/media-gfx/xfig/xfig-3.2.9.ebuild
new file mode 100644
index 000000000000..c264b39dadc8
--- /dev/null
+++ b/media-gfx/xfig/xfig-3.2.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature xdg
+
+DESCRIPTION="A menu-driven tool to draw and manipulate objects interactively in an X window"
+HOMEPAGE="https://mcj.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/mcj/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+COMMON_DEPEND="
+ app-text/ghostscript-gpl:=
+ >=media-gfx/fig2dev-${PV}
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ x11-libs/libX11
+ x11-libs/libXaw3d[unicode(+)]
+ x11-libs/libXpm
+ x11-libs/libXt
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/font-misc-misc
+ media-fonts/urw-fonts
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.6a-solaris.patch"
+ "${FILESDIR}/${PN}-3.2.9-app-defaults.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}" # it expects docdir...
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "GIF support" media-libs/netpbm virtual/imagemagick-tools
+}