summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-07-09 14:18:06 +0000
committerSam James <sam@gentoo.org>2023-07-11 05:34:19 +0100
commit177134bd1b059a651d7644a0c983444b4d122db4 (patch)
treefdc5207e1119e0ec60489cdb954763dad97c7f65 /media-gfx
parentdev-libs/tinyxml2: Fix build with musl 1.2.4 (diff)
downloadgentoo-177134bd1b059a651d7644a0c983444b4d122db4.tar.gz
gentoo-177134bd1b059a651d7644a0c983444b4d122db4.tar.bz2
gentoo-177134bd1b059a651d7644a0c983444b4d122db4.zip
media-gfx/openvdb: Fix usage of removed std::auto_ptr
auto_ptr was deprecated in C++11 and removed in C++17. This bug appears to step from log4cplus, where auto_ptr was replaced with unique_ptr in the 2.0 release. OpenVDB attempts to check for this with the LOG4CPLUS_VERSION macro, however it's defined in the log4cplus/version.h header, which is never included. This patch adds the missing include, which fixes the issue with std::auto_ptr. Closes: https://bugs.gentoo.org/901991 Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openvdb/files/openvdb-10.0.1-log4cplus-version.patch14
-rw-r--r--media-gfx/openvdb/openvdb-10.0.1.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/media-gfx/openvdb/files/openvdb-10.0.1-log4cplus-version.patch b/media-gfx/openvdb/files/openvdb-10.0.1-log4cplus-version.patch
new file mode 100644
index 000000000000..039fd3a9df6c
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-10.0.1-log4cplus-version.patch
@@ -0,0 +1,14 @@
+auto_ptr was deprecated in C++11 and removed in C++17. This bug appears to step from log4cplus, where auto_ptr was replaced with unique_ptr in the 2.0 release. OpenVDB attempts to check for this with the LOG4CPLUS_VERSION macro, however it's defined in the log4cplus/version.h header, which is never included. This patch adds the missing include, which fixes the issue with std::auto_ptr.
+
+Bug: https://bugs.gentoo.org/901991
+
+--- a/openvdb/openvdb/util/logging.h
++++ b/openvdb/openvdb/util/logging.h
+@@ -14,6 +14,7 @@
+ #include <log4cplus/layout.h>
+ #include <log4cplus/logger.h>
+ #include <log4cplus/spi/loggingevent.h>
++#include <log4cplus/version.h>
+ #include <algorithm> // for std::remove()
+ #include <cstring> // for ::strrchr()
+ #include <memory>
diff --git a/media-gfx/openvdb/openvdb-10.0.1.ebuild b/media-gfx/openvdb/openvdb-10.0.1.ebuild
index 29778b9e3216..104a9d150db1 100644
--- a/media-gfx/openvdb/openvdb-10.0.1.ebuild
+++ b/media-gfx/openvdb/openvdb-10.0.1.ebuild
@@ -79,6 +79,7 @@ PATCHES=(
"${FILESDIR}/${PN}-9.0.0-fix-atomic.patch"
"${FILESDIR}/${PN}-10.0.1-fix-linking-of-vdb_tool-with-OpenEXR.patch"
"${FILESDIR}/${PN}-10.0.1-drop-failing-tests.patch"
+ "${FILESDIR}/${PN}-10.0.1-log4cplus-version.patch"
)
pkg_setup() {