summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-14 21:56:02 -0600
committerSam James <sam@gentoo.org>2024-06-20 18:53:03 +0100
commit739de604351be5e93d976fc298acf96366191310 (patch)
tree5b33669e4cd65783704485ec641b87a8921318cb /media-gfx
parentx11-plugins/wmweather: Stabilize 2.4.8 amd64, #933630 (diff)
downloadgentoo-739de604351be5e93d976fc298acf96366191310.tar.gz
gentoo-739de604351be5e93d976fc298acf96366191310.tar.bz2
gentoo-739de604351be5e93d976fc298acf96366191310.zip
media-gfx/qrencode: add multilib
It's going to be required by >=ffmpeg-7.0 Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/37166 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qrencode/qrencode-4.1.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/qrencode/qrencode-4.1.1-r1.ebuild b/media-gfx/qrencode/qrencode-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..50397719faa4
--- /dev/null
+++ b/media-gfx/qrencode/qrencode-4.1.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for encoding data in a QR Code symbol"
+HOMEPAGE="https://fukuchi.org/works/qrencode/"
+SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="png test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="png? ( media-libs/libpng:0=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local myconf=(
+ $(multilib_native_with tools)
+ $(use_with png)
+ $(use_with test tests)
+ # TODO: figure out how to make SDL check fail as the SDL test
+ # program is not useful
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_test() {
+ cp "${S}"/tests/test_basic.sh "${BUILD_DIR}"/tests || die
+ cd tests || die
+ ./test_basic.sh || die
+}
+
+multilib_src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}