summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-06-18 14:33:18 +0200
committerMarek Szuba <marecki@gentoo.org>2020-06-18 14:36:30 +0200
commitb575407bab33bc18c0a521c4fb193cdde6830409 (patch)
tree15c30f58b4334b8ef1dd37a36528283ffd9fbe3b /media-gfx
parentmedia-gfx/darktable: update the live ebuild (diff)
downloadgentoo-b575407bab33bc18c0a521c4fb193cdde6830409.tar.gz
gentoo-b575407bab33bc18c0a521c4fb193cdde6830409.tar.bz2
gentoo-b575407bab33bc18c0a521c4fb193cdde6830409.zip
media-gfx/darktable: patch CMake error in OpenCL testing
Backported the upstream fix from master, i.e. the next release should already include it. Closes: https://bugs.gentoo.org/716358 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/darktable/darktable-3.0.2.ebuild1
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch28
2 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/darktable/darktable-3.0.2.ebuild b/media-gfx/darktable/darktable-3.0.2.ebuild
index 2c9eb9a00a34..a34bc47503e0 100644
--- a/media-gfx/darktable/darktable-3.0.2.ebuild
+++ b/media-gfx/darktable/darktable-3.0.2.ebuild
@@ -71,6 +71,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}"/"${PN}"-find-opencl-header.patch
+ "${FILESDIR}"/${PN}-3.0.2_cmake-opencl-kernel-loop.patch
)
S="${WORKDIR}/${P/_/~}"
diff --git a/media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch b/media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch
new file mode 100644
index 000000000000..c1fd701fb9a4
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch
@@ -0,0 +1,28 @@
+From 767d48e0f60e7f858e8b31a88dd8cc1258e7ee9e Mon Sep 17 00:00:00 2001
+From: Marcus Haehnel <marcus@mh-development.info>
+Date: Sat, 21 Mar 2020 09:14:45 +0100
+Subject: [PATCH] Fix invalid CMake syntax
+
+The syntax of the foreach statement in data/kernels/CMakeLists.txt
+was invalid. This lead to errors when running cmake.
+
+Use correct syntax to make the build work.
+---
+ data/kernels/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/kernels/CMakeLists.txt b/data/kernels/CMakeLists.txt
+index ce947bef9c..f605c18b7e 100644
+--- a/data/kernels/CMakeLists.txt
++++ b/data/kernels/CMakeLists.txt
+@@ -31,8 +31,8 @@ macro (testcompile_opencl_kernel IN)
+ endmacro (testcompile_opencl_kernel)
+
+ if (TESTBUILD_OPENCL_PROGRAMS)
+- foreach(IN ${DT_OPENCL_KERNELS})
+- testcompile_opencl_kernel(${IN})
++ foreach(KERNEL IN ITEMS ${DT_OPENCL_KERNELS})
++ testcompile_opencl_kernel(${KERNEL})
+ endforeach()
+ endif()
+