summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/a52dec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/a52dec')
-rw-r--r--media-libs/a52dec/Manifest1
-rw-r--r--media-libs/a52dec/a52dec-0.7.4-r6.ebuild60
-rw-r--r--media-libs/a52dec/a52dec-0.7.4-r7.ebuild63
-rw-r--r--media-libs/a52dec/files/a52dec-0.7.4-build.patch27
-rw-r--r--media-libs/a52dec/files/a52dec-0.7.4-freebsd.patch11
-rw-r--r--media-libs/a52dec/files/a52dec-0.7.4-test-hidden-symbols.patch19
-rw-r--r--media-libs/a52dec/files/a52dec-0.7.4-tests-optional.patch10
-rw-r--r--media-libs/a52dec/metadata.xml8
8 files changed, 199 insertions, 0 deletions
diff --git a/media-libs/a52dec/Manifest b/media-libs/a52dec/Manifest
new file mode 100644
index 000000000000..d2093b3adebb
--- /dev/null
+++ b/media-libs/a52dec/Manifest
@@ -0,0 +1 @@
+DIST a52dec-0.7.4.tar.gz 241507 SHA256 a21d724ab3b3933330194353687df82c475b5dfb997513eef4c25de6c865ec33 SHA512 4b26fe9492f218b775fb190b76ecf06edaeb656adfe6dcbd24d0a0f86871c3ba917edb88a398eb12dccedaa1605b6f0a0be06b09f9fddd9a46e457b7dd244848 WHIRLPOOL 6dd6454f88ab9c4d80374ac2019d4392765fb3fffc54e0f0367f5c1a7ec31bb38b8b817e05fa195bf4ff83c59adf51872a93e4d61ffcb1e723e13e4a6288bf32
diff --git a/media-libs/a52dec/a52dec-0.7.4-r6.ebuild b/media-libs/a52dec/a52dec-0.7.4-r6.ebuild
new file mode 100644
index 000000000000..f95df3f40017
--- /dev/null
+++ b/media-libs/a52dec/a52dec-0.7.4-r6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="library for decoding ATSC A/52 streams used in DVD"
+HOMEPAGE="http://liba52.sourceforge.net/"
+SRC_URI="http://liba52.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="djbfft oss static-libs"
+
+RDEPEND="djbfft? ( sci-libs/djbfft )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-freebsd.patch \
+ "${FILESDIR}"/${P}-tests-optional.patch \
+ "${FILESDIR}"/${P}-test-hidden-symbols.patch
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #466978
+
+ eautoreconf
+# epunt_cxx is not required with eautoreconf wrt #458298
+# epunt_cxx
+}
+
+src_configure() {
+ filter-flags -fprefetch-loop-arrays
+
+ local myconf
+ use oss || myconf="${myconf} --disable-oss"
+
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable djbfft) \
+ ${myconf}
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /usr/include/a52dec
+ doins liba52/a52_internal.h
+
+ dodoc AUTHORS ChangeLog HISTORY NEWS README TODO doc/liba52.txt
+
+ prune_libtool_files --all
+}
diff --git a/media-libs/a52dec/a52dec-0.7.4-r7.ebuild b/media-libs/a52dec/a52dec-0.7.4-r7.ebuild
new file mode 100644
index 000000000000..71d655b0b709
--- /dev/null
+++ b/media-libs/a52dec/a52dec-0.7.4-r7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="library for decoding ATSC A/52 streams used in DVD"
+HOMEPAGE="http://liba52.sourceforge.net/"
+SRC_URI="http://liba52.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="djbfft oss static-libs"
+
+RDEPEND="djbfft? ( >=sci-libs/djbfft-0.76-r2[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r8
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog HISTORY NEWS README TODO doc/liba52.txt )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-freebsd.patch \
+ "${FILESDIR}"/${P}-tests-optional.patch \
+ "${FILESDIR}"/${P}-test-hidden-symbols.patch
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #466978
+
+ eautoreconf
+
+ filter-flags -fprefetch-loop-arrays
+}
+
+multilib_src_configure() {
+ local myconf
+ use oss || myconf="${myconf} --disable-oss"
+
+ ECONF_SOURCE="${S}" econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable djbfft) \
+ ${myconf}
+
+ # remove useless subdirs
+ if ! multilib_is_native_abi ; then
+ sed -i \
+ -e 's/ src//' \
+ -e 's/ libao//' \
+ Makefile || die
+ fi
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}
diff --git a/media-libs/a52dec/files/a52dec-0.7.4-build.patch b/media-libs/a52dec/files/a52dec-0.7.4-build.patch
new file mode 100644
index 000000000000..f3a29f303ceb
--- /dev/null
+++ b/media-libs/a52dec/files/a52dec-0.7.4-build.patch
@@ -0,0 +1,27 @@
+diff -Naur a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am
+--- a52dec-0.7.4.orig/liba52/Makefile.am 2002-01-27 20:36:48.000000000 -0800
++++ a52dec-0.7.4/liba52/Makefile.am 2004-11-05 01:10:21.317401872 -0800
+@@ -1,4 +1,3 @@
+-CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
+
+ lib_LTLIBRARIES = liba52.la
+
+diff -Naur a52dec-0.7.4.orig/liba52/configure.incl a52dec-0.7.4/liba52/configure.incl
+--- a52dec-0.7.4.orig/liba52/configure.incl 2002-01-27 20:36:48.000000000 -0800
++++ a52dec-0.7.4/liba52/configure.incl 2004-11-05 01:11:38.172672216 -0800
+@@ -2,7 +2,6 @@
+ AC_SUBST([LIBA52_LIBS])
+
+ dnl avoid -fPIC when possible
+-LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic"
+
+ AC_ARG_ENABLE([double],
+ [ --enable-double use double-precision samples])
+diff -Naur a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am
+--- a52dec-0.7.4.orig/src/Makefile.am 2002-06-22 18:51:57.000000000 -0700
++++ a52dec-0.7.4/src/Makefile.am 2004-11-05 01:10:21.320401375 -0800
+@@ -1,4 +1,3 @@
+-CFLAGS = @A52DEC_CFLAGS@
+
+ bin_PROGRAMS = a52dec extract_a52
+ a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c
diff --git a/media-libs/a52dec/files/a52dec-0.7.4-freebsd.patch b/media-libs/a52dec/files/a52dec-0.7.4-freebsd.patch
new file mode 100644
index 000000000000..6e33f18911b3
--- /dev/null
+++ b/media-libs/a52dec/files/a52dec-0.7.4-freebsd.patch
@@ -0,0 +1,11 @@
+--- libao/audio_out_oss.c 2002-04-28 12:23:02 +0200
++++ libao/audio_out_oss.c 2005-07-23 15:42:50 +0200
+@@ -35,7 +35,7 @@
+ #if defined(__OpenBSD__)
+ #include <soundcard.h>
+ #elif defined(__FreeBSD__)
+-#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+ #ifndef AFMT_S16_NE
+ #include <machine/endian.h>
+ #if BYTE_ORDER == LITTLE_ENDIAN
diff --git a/media-libs/a52dec/files/a52dec-0.7.4-test-hidden-symbols.patch b/media-libs/a52dec/files/a52dec-0.7.4-test-hidden-symbols.patch
new file mode 100644
index 000000000000..9ff949dd9c08
--- /dev/null
+++ b/media-libs/a52dec/files/a52dec-0.7.4-test-hidden-symbols.patch
@@ -0,0 +1,19 @@
+2010-07-26 Martin Rejman <martin.rejman@centrum.cz>
+
+ #327369
+ * test/globals: bad_globals: Use readelf and ignore hidden symbols
+
+--- a/test/globals 2010-07-07 20:37:49.000000000 +0200
++++ b/test/globals 2010-07-07 20:37:57.000000000 +0200
+@@ -12,8 +12,9 @@
+ srcdir=`cd $srcdir;pwd`
+ builddir=`cd $builddir;pwd`
+
+-bad_globals=`nm -g --defined-only $builddir/../liba52/*.o|\
+- awk '{if ($3) print $3}'|grep -v '^_\?a52_'`
++bad_globals=`readelf -s $builddir/../liba52/*.o |\
++ awk '$5=="GLOBAL" && $6!="HIDDEN" && $7!="UND" {print $8}' |\
++ grep -v '^_\?a52_'`
+
+ if test x"$bad_globals" != x""; then
+ echo BAD GLOBAL SYMBOLS:
diff --git a/media-libs/a52dec/files/a52dec-0.7.4-tests-optional.patch b/media-libs/a52dec/files/a52dec-0.7.4-tests-optional.patch
new file mode 100644
index 000000000000..6958ef7b4904
--- /dev/null
+++ b/media-libs/a52dec/files/a52dec-0.7.4-tests-optional.patch
@@ -0,0 +1,10 @@
+Index: a52dec-0.7.4/test/Makefile.am
+===================================================================
+--- a52dec-0.7.4.orig/test/Makefile.am
++++ a52dec-0.7.4/test/Makefile.am
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = compare
++check_PROGRAMS = compare
+ compare_SOURCES = compare.c
+ compare_LDADD = -lm
+
diff --git a/media-libs/a52dec/metadata.xml b/media-libs/a52dec/metadata.xml
new file mode 100644
index 000000000000..68068cea75e4
--- /dev/null
+++ b/media-libs/a52dec/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="djbfft">Prefer D.J. Bernstein's library for fourier transforms</flag>
+ </use>
+</pkgmetadata>