summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-25 08:21:01 +0000
committerSam James <sam@gentoo.org>2023-04-26 05:02:35 +0100
commitd4a533b6e778af224bf67f9a45c3fc065774c0e4 (patch)
tree1980bb045a745aae4206bbcc1183c4dc2e62fcbd /media-libs/exiftool
parentmedia-libs/exiftool: drop 12.59 (diff)
downloadgentoo-d4a533b6e778af224bf67f9a45c3fc065774c0e4.tar.gz
gentoo-d4a533b6e778af224bf67f9a45c3fc065774c0e4.tar.bz2
gentoo-d4a533b6e778af224bf67f9a45c3fc065774c0e4.zip
media-libs/exiftool: Add 12.61
New bugfix release. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/30746 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/exiftool')
-rw-r--r--media-libs/exiftool/Manifest3
-rw-r--r--media-libs/exiftool/exiftool-12.61.ebuild26
2 files changed, 27 insertions, 2 deletions
diff --git a/media-libs/exiftool/Manifest b/media-libs/exiftool/Manifest
index 263e6fad3c18..3a533d630957 100644
--- a/media-libs/exiftool/Manifest
+++ b/media-libs/exiftool/Manifest
@@ -1,4 +1,3 @@
-DIST Image-ExifTool-12.42.tar.gz 5042086 BLAKE2B c518906dfc6c354a6bf834044322727ff0c6787f74c387fb24b2320072bb525fd8b0b55d74cc324ac6e2ad6e75de0f3c552db2f6a1e665ab4b1bed9117916c2b SHA512 f7d3dd98623f44473f67ccf740370fd7704b60274efe1272b5219599dba9fe312afe4107937c6d64c5ee11380914b6e97a5248a2abcf88820822f9947cae0f8f
DIST Image-ExifTool-12.50.tar.gz 5088286 BLAKE2B bfc0eae786e1443df5f741f5deed339b76b3041ab939c45303775df9ad22d989bbd68b77c9b8f2259c493dd81828b31223e604ef8bb4867c952cfb892a38a9d5 SHA512 d95be3636ed139a41a14183fc31fa2ecb5ea71b570ccdd282b9f0bba84a264b2edff2c42b34ee1114a14b106383d5ab3b67b8e73642e534f4df3fa54082dba85
-DIST Image-ExifTool-12.59.tar.gz 5202827 BLAKE2B 00a88c3c7239dbcb086469ea5929005ba5bee3230f043bf516fdac92f758ea36fab99f5667a25a7216b35f409d62db3d9cf27b075c0d8ef680e1fbb2b921a3eb SHA512 e17fc293b71a00ae083017f01c50f346cad06f095b7ba279033097285e9f0cdbb917e7b09f1cac6515113e096ca34dafe8eb48fbaa617e62a5fd3dffff505356
DIST Image-ExifTool-12.60.tar.gz 5204922 BLAKE2B 6b4012d722153756a1bb289422d5546395d0be185fcbdc9b954aa3a4d6814ca36fbfc19053889ec864bebe229b4857dc0f9b00b551d1d369de3b97facb7e6117 SHA512 3a581bfd5a75b48b13063f4d169cc167fd027c029bf5d05111d51e789ce9344dcec40b3b7e4f6a9e10ce5599ece514bc0689e93b3aef6bd7db1498537d10899f
+DIST Image-ExifTool-12.61.tar.gz 5207863 BLAKE2B 814cc48ef7d89ea64f22e480964ba7ba9613feb3213420a594b141353a269990e2651a899326cfcd88c387ac810e6e1b4ae817903ae9353b7ee21bef75cf8306 SHA512 bf45b6f838dfe04c5820eb7b1ab65a74b8e2079d56be7ae0382d6c88965f5506cd8e4331232531fdf28d9bf4ebd5b649d0d2afc09977b1de923a8f1a7f6955fb
diff --git a/media-libs/exiftool/exiftool-12.61.ebuild b/media-libs/exiftool/exiftool-12.61.ebuild
new file mode 100644
index 000000000000..4602af41803e
--- /dev/null
+++ b/media-libs/exiftool/exiftool-12.61.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ http://exiftool.sourceforge.net"
+SRC_URI="https://exiftool.org/${DIST_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}