summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-10 20:43:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-06 22:33:14 +0200
commit2ef83bfaadaa71aec36fa57a9ebc1af6d656cd73 (patch)
treefe5ac816028d0ab831ba6bbb8acc174c3ad9edf9 /media-libs/glm
parentkde-plasma/kpipewire: Add missing test USEdep (diff)
downloadgentoo-2ef83bfaadaa71aec36fa57a9ebc1af6d656cd73.tar.gz
gentoo-2ef83bfaadaa71aec36fa57a9ebc1af6d656cd73.tar.bz2
gentoo-2ef83bfaadaa71aec36fa57a9ebc1af6d656cd73.zip
media-libs/glm: drop 0.9.9.8-r1
Closes: https://bugs.gentoo.org/926345 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/glm')
-rw-r--r--media-libs/glm/Manifest1
-rw-r--r--media-libs/glm/files/glm-0.9.9.8-clang.patch11
-rw-r--r--media-libs/glm/glm-0.9.9.8-r1.ebuild62
3 files changed, 0 insertions, 74 deletions
diff --git a/media-libs/glm/Manifest b/media-libs/glm/Manifest
index 9701cf7e2d20..657fb9fb3084 100644
--- a/media-libs/glm/Manifest
+++ b/media-libs/glm/Manifest
@@ -1,2 +1 @@
-DIST glm-0.9.9.8.tar.gz 4368032 BLAKE2B 41e4d4a9fbd75c6c6717e43b6a6ae09bb7da3b4b2ee7c5b04308f3aa875b306638b638aca3e457c039845c489fcf0716a080ec2166bf5e9db93c25944f4ba81a SHA512 9484b0c12175414237c5b9486a2990099b1cb727e442f25ecda18b081aa661f7e92a44481f642989553cd3da7992a773441ee5688991bd539ce19fb66a5ce9e8
DIST glm-1.0.1.tar.gz 4567161 BLAKE2B 2a6f399710f5812d4060b994df454e0c0e4fc7fcaccdfa62de6de2886987349b266944313539a398733708043c887f1324fe33eef8aa2205ef77e7c0dff28fec SHA512 c6c6fa1ea7a7e97820e36ee042a78be248ae828c99c1b1111080d9bf334a5160c9993a70312351c92a867cd49907c95f9f357c8dfe2bc29946da6e83e27ba20c
diff --git a/media-libs/glm/files/glm-0.9.9.8-clang.patch b/media-libs/glm/files/glm-0.9.9.8-clang.patch
deleted file mode 100644
index af763d5b452a..000000000000
--- a/media-libs/glm/files/glm-0.9.9.8-clang.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/test/CMakeLists.txt 2020-07-07 08:44:31.304955458 +0200
-+++ b/test/CMakeLists.txt 2020-07-07 08:44:38.962844309 +0200
-@@ -197,7 +197,7 @@
- message("GLM: Clang - ${CMAKE_CXX_COMPILER_ID} compiler")
- endif()
-
-- add_compile_options(-Werror -Weverything)
-+ add_compile_options(-Weverything)
- add_compile_options(-Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-c++11-long-long -Wno-padded -Wno-gnu-anonymous-struct -Wno-nested-anon-types)
- add_compile_options(-Wno-undefined-reinterpret-cast -Wno-sign-conversion -Wno-unused-variable -Wno-missing-prototypes -Wno-unreachable-code -Wno-missing-variable-declarations -Wno-sign-compare -Wno-global-constructors -Wno-unused-macros -Wno-format-nonliteral)
-
diff --git a/media-libs/glm/glm-0.9.9.8-r1.ebuild b/media-libs/glm/glm-0.9.9.8-r1.ebuild
deleted file mode 100644
index 8c3edfc5425a..000000000000
--- a/media-libs/glm/glm-0.9.9.8-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="OpenGL Mathematics"
-HOMEPAGE="http://glm.g-truc.net/"
-SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( HappyBunny MIT )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86"
-IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9.9.6-simd.patch
- "${FILESDIR}"/${P}-clang.patch
- "${FILESDIR}"/${PN}-0.9.9.8-big-endian-tests.patch
-)
-
-src_configure() {
- # Header-only library
- if use test; then
- # See https://github.com/g-truc/glm/pull/1087
- # https://bugs.gentoo.org/818235
- test-flag-CXX -fno-ipa-modref && append-cxxflags -fno-ipa-modref
-
- local mycmakeargs=(
- -DGLM_TEST_ENABLE=ON
- -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
- -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
- -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
- -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
- )
- cmake_src_configure
- fi
-
- sed \
- -e "s:@CMAKE_INSTALL_PREFIX@:${EPREFIX}/usr:" \
- -e "s:@GLM_VERSION@:$(ver_cut 1-3):" \
- "${FILESDIR}"/glm.pc.in \
- > "${BUILD_DIR}/glm.pc" || die
-}
-
-src_compile() {
- # Header-only library
- if use test; then
- cmake_src_compile
- fi
-}
-
-src_install() {
- doheader -r glm
- insinto /usr/share/pkgconfig
- doins "${BUILD_DIR}/glm.pc"
- insinto /usr/share
- doins -r cmake
- dodoc readme.md manual.md
-}