summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/grilo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/Manifest2
-rw-r--r--media-libs/grilo/files/grilo-0.1.16-constants.py50
-rw-r--r--media-libs/grilo/grilo-0.2.11.ebuild87
-rw-r--r--media-libs/grilo/grilo-0.2.12.ebuild87
-rw-r--r--media-libs/grilo/metadata.xml12
5 files changed, 238 insertions, 0 deletions
diff --git a/media-libs/grilo/Manifest b/media-libs/grilo/Manifest
new file mode 100644
index 000000000000..4c5d636bba30
--- /dev/null
+++ b/media-libs/grilo/Manifest
@@ -0,0 +1,2 @@
+DIST grilo-0.2.11.tar.xz 614060 SHA256 8a52c37521de80d6caf08a519a708489b9e2b097c2758a0acaab6fbd26d30ea6 SHA512 1e1538ee6657b25bdf902e6b2fd0a75409a8c0a72ebfc1a43c10464e33c2b2455943a4a76491ee9470bdf8f6d934f28fa385fef9f61f0020e943adc01b3a194e WHIRLPOOL 4b9f84a7340e1ca8ae5d27107da6112dbb006da481f5ee39f097b965645ef5f08960ad6520107a683ec060cc7ff6219408d649d116ca44c4521cc1cd64f3a4cb
+DIST grilo-0.2.12.tar.xz 617284 SHA256 55b4663550bc8185f8db232e96b9ba99fbfa9175e31e7321fa5ccaacf3617b85 SHA512 a8102dc66e30676a3fcf2be1c96b4c461b78095c03d7566216bb6c04f875b3be6a305d81464058a11f92dee00e68b2abdcb8d5c5f2a0d95732ac7dbb473820f4 WHIRLPOOL fece087c8003138e9b6a977cb3c9d60dd41364dd6b7cb2efe98efab863e38ea360daf44b90ec7a970810a8b4a980221ef73e8a4606dca8e26e52f36980ba9ffc
diff --git a/media-libs/grilo/files/grilo-0.1.16-constants.py b/media-libs/grilo/files/grilo-0.1.16-constants.py
new file mode 100644
index 000000000000..e8e26906a79f
--- /dev/null
+++ b/media-libs/grilo/files/grilo-0.1.16-constants.py
@@ -0,0 +1,50 @@
+KEY_NONEXISTING = 'nonexisting-key'
+KEY_ALBUM = 'album'
+KEY_ARTIST = 'artist'
+KEY_AUTHOR = 'author'
+KEY_BITRATE = 'bitrate'
+KEY_CERTIFICATE = 'certificate'
+KEY_CHILDCOUNT = 'childcount'
+KEY_DATE = 'date'
+KEY_DESCRIPTION = 'description'
+KEY_DURATION = 'duration'
+KEY_EXTERNAL_PLAYER = 'external-player'
+KEY_EXTERNAL_URL = 'external-url'
+KEY_FRAMERATE = 'framerate'
+KEY_GENRE = 'genre'
+KEY_HEIGHT = 'height'
+KEY_ID = 'id'
+KEY_LAST_PLAYED = 'last-played'
+KEY_LAST_POSITION = 'last-position'
+KEY_LICENSE = 'license'
+KEY_LYRICS = 'lyrics'
+KEY_MIME = 'mime'
+KEY_PLAY_COUNT = 'play-count'
+KEY_RATING = 'rating'
+KEY_SITE = 'site'
+KEY_SOURCE = 'source'
+KEY_STUDIO = 'studio'
+KEY_THUMBNAIL = 'thumbnail'
+KEY_TITLE = 'title'
+KEY_URL = 'url'
+KEY_WIDTH = 'width'
+
+REGISTERED_KEYS = [KEY_ALBUM, KEY_ARTIST, KEY_AUTHOR, KEY_BITRATE,
+ KEY_CERTIFICATE, KEY_CHILDCOUNT, KEY_DATE,
+ KEY_DESCRIPTION, KEY_DURATION, KEY_EXTERNAL_PLAYER,
+ KEY_EXTERNAL_URL, KEY_FRAMERATE, KEY_GENRE, KEY_HEIGHT,
+ KEY_ID, KEY_LAST_PLAYED, KEY_LAST_POSITION, KEY_LICENSE,
+ KEY_LYRICS, KEY_MIME, KEY_PLAY_COUNT, KEY_RATING,
+ KEY_SITE, KEY_SOURCE, KEY_STUDIO, KEY_THUMBNAIL,
+ KEY_TITLE, KEY_URL, KEY_WIDTH]
+
+SUPPORTED_OPS = []
+try:
+ from gi.repository import Grl
+ SUPPORTED_OPS = [Grl.SupportedOps.NONE, Grl.SupportedOps.METADATA,
+ Grl.SupportedOps.RESOLVE, Grl.SupportedOps.BROWSE,
+ Grl.SupportedOps.SEARCH, Grl.SupportedOps.QUERY,
+ Grl.SupportedOps.STORE, Grl.SupportedOps.STORE_PARENT,
+ Grl.SupportedOps.REMOVE, Grl.SupportedOps.SET_METADATA]
+except:
+ pass
diff --git a/media-libs/grilo/grilo-0.2.11.ebuild b/media-libs/grilo/grilo-0.2.11.ebuild
new file mode 100644
index 000000000000..5137206f894f
--- /dev/null
+++ b/media-libs/grilo/grilo-0.2.11.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION="0.12"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 python-any-r1 vala
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2/1" # subslot is libgrilo-0.2 soname suffix
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+IUSE="gtk examples +introspection +network playlist test vala"
+REQUIRED_USE="test? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ dev-libs/libxml2:2
+ net-libs/liboauth
+ gtk? ( >=x11-libs/gtk+-3:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9 )
+ network? ( >=net-libs/libsoup-2.41.3:2.4 )
+ playlist? ( >=dev-libs/totem-pl-parser-3.4.1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ media-plugins/grilo-plugins:0.2 )
+"
+# eautoreconf requires gnome-common
+
+python_check_deps() {
+ has_version "dev-python/pygobject:2[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build examples
+ sed -e '/SUBDIRS/s/examples//' \
+ -i Makefile.am -i Makefile.in || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ $(use_enable gtk test-ui) \
+ $(use_enable introspection) \
+ $(use_enable network grl-net) \
+ $(use_enable playlist grl-pls) \
+ $(use_enable test tests) \
+ $(use_enable vala)
+}
+
+src_install() {
+ gnome2_src_install
+ # Upstream made this conditional on gtk-doc build...
+ emake -C doc install DESTDIR="${ED}"
+
+ if use examples; then
+ # Install example code
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}
diff --git a/media-libs/grilo/grilo-0.2.12.ebuild b/media-libs/grilo/grilo-0.2.12.ebuild
new file mode 100644
index 000000000000..796c66c18eb5
--- /dev/null
+++ b/media-libs/grilo/grilo-0.2.12.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION="0.27"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 python-any-r1 vala
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2/1" # subslot is libgrilo-0.2 soname suffix
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk examples +introspection +network playlist test vala"
+REQUIRED_USE="test? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.43.1:2
+ dev-libs/libxml2:2
+ net-libs/liboauth
+ gtk? ( >=x11-libs/gtk+-3:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9 )
+ network? ( >=net-libs/libsoup-2.41.3:2.4 )
+ playlist? ( >=dev-libs/totem-pl-parser-3.4.1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ media-plugins/grilo-plugins:0.2 )
+"
+# eautoreconf requires gnome-common
+
+python_check_deps() {
+ has_version "dev-python/pygobject:2[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build examples
+ sed -e '/SUBDIRS/s/examples//' \
+ -i Makefile.am -i Makefile.in || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ $(use_enable gtk test-ui) \
+ $(use_enable introspection) \
+ $(use_enable network grl-net) \
+ $(use_enable playlist grl-pls) \
+ $(use_enable test tests) \
+ $(use_enable vala)
+}
+
+src_install() {
+ gnome2_src_install
+ # Upstream made this conditional on gtk-doc build...
+ emake -C doc install DESTDIR="${ED}"
+
+ if use examples; then
+ # Install example code
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}
diff --git a/media-libs/grilo/metadata.xml b/media-libs/grilo/metadata.xml
new file mode 100644
index 000000000000..08f4481ad1f9
--- /dev/null
+++ b/media-libs/grilo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name='network'>Enable network access for media discovery using
+ <pkg>net-libs/libsoup</pkg></flag>
+ <flag name='playlist'>Enable support for playlists through
+ <pkg>dev-libs/totem-pl-parser</pkg></flag>
+ <flag name='vala'>Generate bindings for <pkg>dev-lang/vala</pkg></flag>
+ </use>
+</pkgmetadata>