summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-05-08 12:55:49 +0300
committerSam James <sam@gentoo.org>2022-05-12 22:42:34 +0000
commit3915b764b76507c595f389ff6870bb1d79c3ef52 (patch)
treed9f568b7773c195ce68a88f4581e5f318c30e7dd /media-libs/gst-plugins-bad
parentapp-emacs/haxe-mode: new package; add version 0.3.3 (diff)
downloadgentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.tar.gz
gentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.tar.bz2
gentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.zip
media-libs/gstreamer: Version bump, 1.20.2
Bug: https://bugs.gentoo.org/843770 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/Manifest1
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index 4003cc12c92a..386a4b50cda9 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -3,3 +3,4 @@ DIST gst-plugins-bad-1.18.4-glib-volatile.patch.bz2 8492 BLAKE2B 7a6e4a3fc1d68c3
DIST gst-plugins-bad-1.18.4.tar.xz 5640292 BLAKE2B 5385abe635a35f61c6780e6cfa1189835877b8c0a12145de6890708a097fc453b1abfb14a3497cae4e6961f71fc2c6e01759fe19386cd30a64c4069704ddf77a SHA512 02123e054419f5ce6ca2ebe0bdf23572269ea4120bf463b4d672efbe5d9e5d417d4d711cc80094be974c4569f754d8b2ad93f59b827e3b018d450582834cb125
DIST gst-plugins-bad-1.18.6.tar.xz 5652788 BLAKE2B d877c8b6d39b67de957f180fbcc942fc658631dfc75b90f342f088e58c4655b1591651fbcd2a98259c95f0a7e830bb0ec67f65eb87d4b13c9f2adc733da7f12f SHA512 78731e0db04afd3dcdd5c5ea84df4e096a5db121fd9cb6eb79197844482a3b36b2764a664f171f80c809e6182ceae2350113d47f3f7c684d2d88f752bc092baf
DIST gst-plugins-bad-1.20.1.tar.xz 6212148 BLAKE2B e88f6553668329abb7b787c5efb89d760e60009fb9bd23884aa54e5a8de94f50b9fc9cd74cb2d303d43511207574f447bf616d8f9836df5dcde767c4ee5bff4d SHA512 3113fc93bba59716e7a506cf00f88cb05ccfe3406515ecf7e377dcfd3a8f4e555ff45126c048dc736ae6a28acf430c96422be4a120889fbe04ed69c5acb1cad6
+DIST gst-plugins-bad-1.20.2.tar.xz 6216208 BLAKE2B bbbe77a1255991a2f96696996fb0c99f14f6d63fef455feb1ce90ae518bb9f80fd61bcfb223c20407b8d6240faaa93478495f8e9fda16fab36a311d167e88e25 SHA512 3f98973dc07ead745418e0a30f9f6b5c8d328e3d126f54d92c10ab5da04271768a5c5dffc36ea24ccf8fb516b1e3733be9fb18dc0db419dea4d37d17018f8a70
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild
new file mode 100644
index 000000000000..ffccda97c31c
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-bad"
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit flag-o-matic gstreamer-meson python-any-r1
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# TODO: egl and gtk IUSE only for transition
+IUSE="X bzip2 +egl gles2 gtk +introspection +opengl +orc vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
+
+# X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
+# We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
+# FIXME gtk? ( >=media-plugins/gst-plugins-gtk-${PV}:${SLOT}[${MULTILIB_USEDEP}] )
+RDEPEND="
+ !media-plugins/gst-transcoder
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
+ wayland? (
+ >=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.15
+ )
+
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+# FIXME: gstharness.c:889:gst_harness_new_with_padnames: assertion failed: (element != NULL)
+RESTRICT="test"
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ addpredict /dev # Prevent sandbox violations bug #570624
+}
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="shm ipcpipeline librfb hls"
+
+ local emesonargs=(
+ -Dshm=enabled
+ -Dipcpipeline=enabled
+ -Dhls=disabled
+ $(meson_feature vnc librfb)
+
+ $(meson_feature wayland)
+ )
+
+ if use opengl || use gles2; then
+ myconf+=( -Dgl=enabled )
+ else
+ myconf+=( -Dgl=disabled )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_test() {
+ # Tests are slower than upstream expects
+ CK_DEFAULT_TIMEOUT=300 gstreamer_multilib_src_test
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}