summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-03-20 20:26:14 -0400
committerSam James <sam@gentoo.org>2023-03-21 04:18:52 +0000
commit78f6905a8bec4121d6f000a3c797487e3f02982f (patch)
treed4659bbf2895067b53806e3d1dd6aec73c01537d /media-libs/libaom
parentx11-themes/tela-icon-theme: re-phrase kde useflag description (diff)
downloadgentoo-78f6905a8bec4121d6f000a3c797487e3f02982f.tar.gz
gentoo-78f6905a8bec4121d6f000a3c797487e3f02982f.tar.bz2
gentoo-78f6905a8bec4121d6f000a3c797487e3f02982f.zip
media-libs/libaom: wire up tests
These tests are VERY long (expect 3+ hours minimum) and currently also DO NOT PASS on non-amd64 arches. Bug: https://bugs.gentoo.org/896122 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/30274 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libaom')
-rw-r--r--media-libs/libaom/Manifest1
-rw-r--r--media-libs/libaom/libaom-3.6.0.ebuild19
-rw-r--r--media-libs/libaom/libaom-9999.ebuild19
3 files changed, 31 insertions, 8 deletions
diff --git a/media-libs/libaom/Manifest b/media-libs/libaom/Manifest
index c87565f3d8c8..8472f6c06f8f 100644
--- a/media-libs/libaom/Manifest
+++ b/media-libs/libaom/Manifest
@@ -1,3 +1,4 @@
DIST libaom-3.4.0.tar.gz 5175838 BLAKE2B 7a38cc1a1871f044018a8ebf5022810b753b099ad61e0c6e2625a0480946e8b5e066fd1e1abc5523e817025c8a59d6f1092c12d632c5b602cf3a80f6ef8daa0e SHA512 8de5e7eae96b182ceb33ce2c66fde784349a7a117371177102c358cc9b2cad75bebe2849fdf8ce57ae149a38b43419b51e54e5475cb781ed3d5953081127b478
DIST libaom-3.5.0.tar.gz 5206715 BLAKE2B d47ddb864c909c972f692667177417daef0350124a096547eacc83ab3630227fe7a23e95f3988a2109c580f9a87ba30a58bcc58be1a2e24fe694eb01655a4861 SHA512 370c529a84d54c95f05c5a3b3edadd1cca95eeccd5a6b5454e574211c6dd9bf5bd33ab67b43587c6de37688fe546ea9e16de0ab2d721e965143b7e8c85db6fd4
+DIST libaom-3.6.0-testdata.tar.gz 498554450 BLAKE2B bbc84e9d3fd91272fa6e30a19f625fb5b71b1ff6c622982202c298e45c7a331338ed316942d7c0ab00f5ef37d442e1a45a62a30be70f8c1315caac9e7742903e SHA512 a86303a2486fca9a85cdb9275c1715a3862df92021967a5a0d97f8aa6862dd6cad1d65e1377fbee3f1b21d73c770e10ece4041a13bf57e6f2a1bb39357b00316
DIST libaom-3.6.0.tar.gz 5258526 BLAKE2B bf97c74f3e59e3cc2431e7b7e3494beffde1b659d1a8f8775b4b47da0c7314b8bf5b9bdf14a9d1d47a8378271f49c9e26676e73509f9e910f1d5a01e79b575bc SHA512 28df178f43f26a064474f7d9c79882b4c04b66fed16f904ac9b37386912660e2af88c90672ec04eed99aef104156cf1e72040fa975895522dca7b88760b138bc
diff --git a/media-libs/libaom/libaom-3.6.0.ebuild b/media-libs/libaom/libaom-3.6.0.ebuild
index b4074f6c48c7..a4a3923a8c6a 100644
--- a/media-libs/libaom/libaom-3.6.0.ebuild
+++ b/media-libs/libaom/libaom-3.6.0.ebuild
@@ -10,7 +10,19 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
- SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
+ # To update test data tarball, follow these steps:
+ # 1. Clone the upstream repo and check out the relevant tag,
+ # or download the release tarball
+ # 2. Regular cmake configure (options don't matter here):
+ # cd build && cmake ..
+ # 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
+ # run the "make testdata" target:
+ # LIBAOM_TEST_DATA_PATH=../libaom-1.2.3-testdata make testdata
+ # This will download the test data from the internet.
+ # 4. Create a tarball out of that directory.
+ # cd .. && tar cvzf libaom-1.2.3-testdata.tar.gz libaom-1.2.3-testdata
+ SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~ionen/distfiles/${P}-testdata.tar.gz )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
@@ -23,8 +35,7 @@ IUSE="doc +examples test"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
IUSE="${IUSE} cpu_flags_arm_neon"
-# Tests need more wiring up
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
@@ -97,7 +108,7 @@ multilib_src_configure() {
}
multilib_src_test() {
- "${BUILD_DIR}"/test_libaom || die
+ LIBAOM_TEST_DATA_PATH="${WORKDIR}/${P}-testdata" "${BUILD_DIR}"/test_libaom || die
}
multilib_src_install() {
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index b4074f6c48c7..a4a3923a8c6a 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -10,7 +10,19 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
- SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
+ # To update test data tarball, follow these steps:
+ # 1. Clone the upstream repo and check out the relevant tag,
+ # or download the release tarball
+ # 2. Regular cmake configure (options don't matter here):
+ # cd build && cmake ..
+ # 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
+ # run the "make testdata" target:
+ # LIBAOM_TEST_DATA_PATH=../libaom-1.2.3-testdata make testdata
+ # This will download the test data from the internet.
+ # 4. Create a tarball out of that directory.
+ # cd .. && tar cvzf libaom-1.2.3-testdata.tar.gz libaom-1.2.3-testdata
+ SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~ionen/distfiles/${P}-testdata.tar.gz )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
@@ -23,8 +35,7 @@ IUSE="doc +examples test"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
IUSE="${IUSE} cpu_flags_arm_neon"
-# Tests need more wiring up
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
@@ -97,7 +108,7 @@ multilib_src_configure() {
}
multilib_src_test() {
- "${BUILD_DIR}"/test_libaom || die
+ LIBAOM_TEST_DATA_PATH="${WORKDIR}/${P}-testdata" "${BUILD_DIR}"/test_libaom || die
}
multilib_src_install() {