summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-22 17:48:59 +0000
committerSam James <sam@gentoo.org>2024-01-01 20:34:24 +0000
commitfd8ce216f3f1f20667ac7bae23a5e5daa1026975 (patch)
tree7abf9e8c26fe2d750f33a558533c60a2828c3301 /media-libs/libmatemixer
parentdev-libs/libmateweather: drop 1.26.0 (diff)
downloadgentoo-fd8ce216f3f1f20667ac7bae23a5e5daa1026975.tar.gz
gentoo-fd8ce216f3f1f20667ac7bae23a5e5daa1026975.tar.bz2
gentoo-fd8ce216f3f1f20667ac7bae23a5e5daa1026975.zip
media-libs/libmatemixer: Add 1.26.1, 1.27.0
fixes missing udev issue and tidy up of depends. Closes: https://bugs.gentoo.org/914081 Closes: https://bugs.gentoo.org/847217 Thanks-to: Alfred Wingate <parona@protonmail.com> Signed-off-by: Ian Jordan <immoloism@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34426 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libmatemixer')
-rw-r--r--media-libs/libmatemixer/Manifest2
-rw-r--r--media-libs/libmatemixer/libmatemixer-1.26.0-r1.ebuild5
-rw-r--r--media-libs/libmatemixer/libmatemixer-1.26.1.ebuild46
-rw-r--r--media-libs/libmatemixer/libmatemixer-1.27.0.ebuild46
4 files changed, 97 insertions, 2 deletions
diff --git a/media-libs/libmatemixer/Manifest b/media-libs/libmatemixer/Manifest
index d6fe4a99dfce..a92e079f1452 100644
--- a/media-libs/libmatemixer/Manifest
+++ b/media-libs/libmatemixer/Manifest
@@ -1 +1,3 @@
DIST libmatemixer-1.26.0.tar.xz 489092 BLAKE2B 4b87b92904f038fb957dd17dfecc91a82597663b3470169658ed1325ffdc7c54f24269c1226fbb696337006729211e61d21af5dcdf18c3d05ce348656ae81f39 SHA512 6e97594f9a43f4e66c31e466d8a46ea5d77cb5b5ead26df6461b1529a3b6f1448768a981e7a527a4c07dda0e4cba7470e1fff8b316731da293cfdc0f18aacc73
+DIST libmatemixer-1.26.1.tar.xz 497560 BLAKE2B a84922fa8743749e0120845a462de84d2057049957207357e4212a1e6201c60bd31b873282764ec2e2380e3a0c76dd498deaef32bdefb9f012b141d9adad280f SHA512 a67a63bbf76b69ba78a537f7690230f45c5875b4358991e73604aacf001baa40ee994101d486218be8000be43be6561b6f25f4f38ae00310c5a08affb6dafbdb
+DIST libmatemixer-1.27.0.tar.xz 497392 BLAKE2B a08c8a04bfed76d41475dc3629b7e9a87755940c6e4a8d39d7b2c7ce3751cc5b4008d3f31ef1af43b2873761d34a9330fc331b132b779320ed19650d75f1562d SHA512 d64d136a013d18364f4f83451b26ea674d9eb611fad44349781aa1e9369e167fe892b9e1fe068f3243bee06babd3811958e301add8034cb6229473eaeb4841e1
diff --git a/media-libs/libmatemixer/libmatemixer-1.26.0-r1.ebuild b/media-libs/libmatemixer/libmatemixer-1.26.0-r1.ebuild
index 08b8e59b93db..b3cd10c1143a 100644
--- a/media-libs/libmatemixer/libmatemixer-1.26.0-r1.ebuild
+++ b/media-libs/libmatemixer/libmatemixer-1.26.0-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit mate
-if [[ ${PV} != 9999 ]]; then
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
fi
diff --git a/media-libs/libmatemixer/libmatemixer-1.26.1.ebuild b/media-libs/libmatemixer/libmatemixer-1.26.1.ebuild
new file mode 100644
index 000000000000..195dc6e0c270
--- /dev/null
+++ b/media-libs/libmatemixer/libmatemixer-1.26.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Mixer library for MATE Desktop"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+alsa pulseaudio +udev"
+REQUIRED_USE="udev? ( alsa )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )
+ pulseaudio? ( media-libs/libpulse[glib] )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig
+"
+
+RDEPEND="${COMMON_DEPEND}
+ alsa? ( udev? ( virtual/libudev:= ) )
+"
+
+DEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mate_src_configure \
+ --disable-null \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio)
+}
diff --git a/media-libs/libmatemixer/libmatemixer-1.27.0.ebuild b/media-libs/libmatemixer/libmatemixer-1.27.0.ebuild
new file mode 100644
index 000000000000..195dc6e0c270
--- /dev/null
+++ b/media-libs/libmatemixer/libmatemixer-1.27.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Mixer library for MATE Desktop"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+alsa pulseaudio +udev"
+REQUIRED_USE="udev? ( alsa )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )
+ pulseaudio? ( media-libs/libpulse[glib] )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig
+"
+
+RDEPEND="${COMMON_DEPEND}
+ alsa? ( udev? ( virtual/libudev:= ) )
+"
+
+DEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mate_src_configure \
+ --disable-null \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio)
+}