summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2021-04-28 01:55:19 +0200
committerSam James <sam@gentoo.org>2021-06-10 00:19:17 +0000
commita8f956e915b79218d56b4af2cb3015b0869c3aaa (patch)
tree86a1eac4945ee236f49e9dbf6639e6b73f593d63 /media-libs/oidn
parentmedia-libs/osl: bump to 1.12.0.2 (diff)
downloadgentoo-a8f956e915b79218d56b4af2cb3015b0869c3aaa.tar.gz
gentoo-a8f956e915b79218d56b4af2cb3015b0869c3aaa.tar.bz2
gentoo-a8f956e915b79218d56b4af2cb3015b0869c3aaa.zip
media-libs/oidn: New package
Intel Open Image Denoise is an open source library of high-performance, high-quality denoising filters for images rendered with ray tracing. Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/oidn')
-rw-r--r--media-libs/oidn/Manifest1
-rw-r--r--media-libs/oidn/metadata.xml20
-rw-r--r--media-libs/oidn/oidn-1.3.0.ebuild39
3 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/oidn/Manifest b/media-libs/oidn/Manifest
new file mode 100644
index 000000000000..d2d55abdbfb2
--- /dev/null
+++ b/media-libs/oidn/Manifest
@@ -0,0 +1 @@
+DIST oidn-1.3.0.tar.gz 36763571 BLAKE2B 395d7aafd87babf7d2414ed940dd85adf4a488df2138e0e63cc82ac06088dd969879de73d79bead4b35bba0045081ee637b72f2a98770dbfc928ffe7c25da78a SHA512 19de3cf11b9d436ee6f33ff020187a4cdc05da5f43c47509f715ca99e4276bfb64425d0a48f3a6f0569c8c6701b46a7e35378f371fdbacc0b6d488e113ffe17c
diff --git a/media-libs/oidn/metadata.xml b/media-libs/oidn/metadata.xml
new file mode 100644
index 000000000000..1787e6d6af0d
--- /dev/null
+++ b/media-libs/oidn/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>darkdefende@gmail.com</email>
+ <name>Sebastian Parborg</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Intel Open Image Denoise is an open source library of high-performance,
+ high-quality denoising filters for images rendered with ray tracing. Intel
+ Open Image Denoise is part of the Intel® oneAPI Rendering Toolkit and is
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenImageDenoise/oidn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/oidn/oidn-1.3.0.ebuild b/media-libs/oidn/oidn-1.3.0.ebuild
new file mode 100644
index 000000000000..7e79c737d50f
--- /dev/null
+++ b/media-libs/oidn/oidn-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+
+inherit cmake python-single-r1 eutils
+
+DESCRIPTION="Intel(R) Open Image Denoise library"
+HOMEPAGE="http://www.openimagedenoise.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenImageDenoise/oidn.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/OpenImageDenoise/${PN}/releases/download/v${PV}/${P}.src.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-cpp/tbb
+ dev-lang/ispc"
+DEPEND="
+ ${RDEPEND}
+ dev-util/cmake"
+
+CMAKE_BUILD_TYPE=Release
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}