summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDustin Smith <smith.dustin2017@gmail.com>2022-04-21 22:22:08 -0400
committerSam James <sam@gentoo.org>2022-04-23 02:20:05 +0100
commitb81fb8d368376faefc0d71a15c44d1cfd9d8dab1 (patch)
tree6fdff9e64b0d72ca681a93ce98b22b841aac6545 /media-libs/opus
parentx11-plugins/gkrellm-cpupower: fix recursive variable CC (diff)
downloadgentoo-b81fb8d368376faefc0d71a15c44d1cfd9d8dab1.tar.gz
gentoo-b81fb8d368376faefc0d71a15c44d1cfd9d8dab1.tar.bz2
gentoo-b81fb8d368376faefc0d71a15c44d1cfd9d8dab1.zip
media-libs/opus: fix word split issue in ebuild
shellbugbot points out an issue with shellcheck where $INTRINSIC_FLAGS won't be split on space because of the double quoting. If I am reading the ebuild correctly, then "use" is receiving one big argument "cpu_flags_x86_sse cpu_flags_arm_neon" in just one iteration. This commit just removes the double quotes to fix this. Bug: https://bugs.gentoo.org/839222 Closes: https://github.com/gentoo/gentoo/pull/25147 Signed-off-by: Dustin Smith <smith.dustin2017@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/opus-1.3.1-r3.ebuild (renamed from media-libs/opus/opus-1.3.1-r2.ebuild)2
1 files changed, 1 insertions, 1 deletions
diff --git a/media-libs/opus/opus-1.3.1-r2.ebuild b/media-libs/opus/opus-1.3.1-r3.ebuild
index 10c7e4876985..e250256c7441 100644
--- a/media-libs/opus/opus-1.3.1-r2.ebuild
+++ b/media-libs/opus/opus-1.3.1-r3.ebuild
@@ -37,7 +37,7 @@ multilib_src_configure() {
# We want to disable intrinsics if no flags are enabled
# (This is a fun Bash construct to do that!)
# bug #752069
- for i in "${INTRINSIC_FLAGS}" ; do
+ for i in ${INTRINSIC_FLAGS} ; do
use ${i} && myeconfargs+=( --enable-intrinsics ) && break
done || myeconfargs+=( --disable-intrinsics )