summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-22 20:47:53 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-03-22 20:47:53 +0000
commit755506b85255d86236beea42d56da56b6c85277f (patch)
treef37b6e969bc551efe47929633b8edbb7b990d80c /media-libs/speex
parentnet-analyzer/wireshark: Mark ~hppa (bug #650642). (diff)
downloadgentoo-755506b85255d86236beea42d56da56b6c85277f.tar.gz
gentoo-755506b85255d86236beea42d56da56b6c85277f.tar.bz2
gentoo-755506b85255d86236beea42d56da56b6c85277f.zip
media-libs/speex: Fix fixed point arithmetic on old ARM
Closes: https://bugs.gentoo.org/617322 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/speex')
-rw-r--r--media-libs/speex/speex-1.2.0-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-libs/speex/speex-1.2.0-r1.ebuild b/media-libs/speex/speex-1.2.0-r1.ebuild
index f692f00185d9..f296eaea347a 100644
--- a/media-libs/speex/speex-1.2.0-r1.ebuild
+++ b/media-libs/speex/speex-1.2.0-r1.ebuild
@@ -42,10 +42,13 @@ multilib_src_configure() {
append-lfs-flags
local \
+ FIXED_ARG=--disable-fixed-point \
ARM4_ARG=--disable-arm4-asm \
ARM5_ARG=--disable-arm5e-asm
if use arm && ! use cpu_flags_arm_v6; then
+ FIXED_ARG=--enable-fixed-point
+
if use cpu_flags_arm_v5; then
ARM5_ARG=--enable-arm5e-asm
elif use cpu_flags_arm_v4; then
@@ -53,15 +56,13 @@ multilib_src_configure() {
fi
fi
- # Can also be configured without floating point
- # --enable-fixed-point
ECONF_SOURCE="${S}" econf \
$(use_enable static-libs static) \
$(use_enable cpu_flags_x86_sse sse) \
$(use_enable vbr) \
$(use_with utils speexdsp) \
$(use_enable utils binaries) \
- ${ARM4_ARG} ${ARM5_ARG}
+ ${FIXED_ARG} ${ARM4_ARG} ${ARM5_ARG}
}
multilib_src_install_all() {