summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-02-12 11:30:52 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-02-12 11:30:52 +0000
commita113c4b96a6bc2fdb7f12e360348b052cd0806c7 (patch)
tree959a323611cc96da48b22e5cd5ecb802b42d5c3c /media-libs/vkroots
parentkde-frameworks/kross: 5.103.0 version bump (diff)
downloadgentoo-a113c4b96a6bc2fdb7f12e360348b052cd0806c7.tar.gz
gentoo-a113c4b96a6bc2fdb7f12e360348b052cd0806c7.tar.bz2
gentoo-a113c4b96a6bc2fdb7f12e360348b052cd0806c7.zip
media-libs/vkroots: Version bump to 0_p20230103
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/vkroots')
-rw-r--r--media-libs/vkroots/Manifest1
-rw-r--r--media-libs/vkroots/vkroots-0_p20230103.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/vkroots/Manifest b/media-libs/vkroots/Manifest
index e0692c735e9b..56a00ee208ba 100644
--- a/media-libs/vkroots/Manifest
+++ b/media-libs/vkroots/Manifest
@@ -1 +1,2 @@
DIST vkroots-0_p20221205.tar.gz 272641 BLAKE2B ee61988cf1a110d39e96f027160cbefb2e3815e9ef60e367b54be94348d2cd75037a7eb115620460ed1c1c36256e919e568551258217e1b12aea760d2c90dd61 SHA512 a1a21f53d38385a5f300d9dd5650145074baad66b081beaab59179995afcc5a8df8adf19d52c5da15a7ee10fa530aa9d24c3ff1e04df3f7e1d3af526abc1e55e
+DIST vkroots-0_p20230103.tar.gz 306308 BLAKE2B 6252faae2e826a84510b3112aab427efcc80cfd23974165652eff930d064c26ea0595d7b9ea7b0f8fb4b92730b56ba56e1013f0c2aedae1ddc2ec392fcf89aa3 SHA512 606395000264647f0e74aeb4699b63e29de367b5c97b8d26c01b9373cc130ae0cf872ffaa56b826ed6e0b4170654df1af8f4272f8ed6f83fcc6f75750e8d3c2a
diff --git a/media-libs/vkroots/vkroots-0_p20230103.ebuild b/media-libs/vkroots/vkroots-0_p20230103.ebuild
new file mode 100644
index 000000000000..335b8e66be27
--- /dev/null
+++ b/media-libs/vkroots/vkroots-0_p20230103.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit meson python-any-r1
+
+COMMIT="26757103dde8133bab432d172b8841df6bb48155"
+DESCRIPTION="Simple framework for writing Vulkan layers"
+HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
+SRC_URI="https://github.com/Joshua-Ashton/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0 MIT LGPL-2.1"
+SLOT="0"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/vulkan-headers
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() {
+ "${PYTHON}" ./gen/make_vkroots --xml "${BROOT}"/usr/share/vulkan/registry/vk.xml || die
+}