summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-07-07 15:45:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-07-07 16:25:01 +0200
commitce96503d6c627004f1abc6094f3e4a044d550216 (patch)
tree7b0edfdeda1a75482a5fc34d4bb1f56b193dffef /media-libs/zimg/zimg-3.0.4.ebuild
parentmedia-libs/libaom: bump to 3.4.0 (diff)
downloadgentoo-ce96503d6c627004f1abc6094f3e4a044d550216.tar.gz
gentoo-ce96503d6c627004f1abc6094f3e4a044d550216.tar.bz2
gentoo-ce96503d6c627004f1abc6094f3e4a044d550216.zip
media-libs/zimg: bump to 3.0.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/zimg/zimg-3.0.4.ebuild')
-rw-r--r--media-libs/zimg/zimg-3.0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-3.0.4.ebuild b/media-libs/zimg/zimg-3.0.4.ebuild
new file mode 100644
index 000000000000..2c7c54c43cfe
--- /dev/null
+++ b/media-libs/zimg/zimg-3.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="debug static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}