summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-12-20 15:15:35 -0500
committerMatt Turner <mattst88@gentoo.org>2023-12-20 15:23:09 -0500
commit0aebd1906345c771db02d0bf05e8bec977b685ba (patch)
tree8514877186a7b92d92c8b86139f031f9b4acb4a4 /media-libs
parentmedia-libs/gmmlib: Version bump to 22.3.15 (diff)
downloadgentoo-0aebd1906345c771db02d0bf05e8bec977b685ba.tar.gz
gentoo-0aebd1906345c771db02d0bf05e8bec977b685ba.tar.bz2
gentoo-0aebd1906345c771db02d0bf05e8bec977b685ba.zip
media-libs/libva-intel-media-driver: Version bump to 23.4.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libva-intel-media-driver/Manifest1
-rw-r--r--media-libs/libva-intel-media-driver/libva-intel-media-driver-23.4.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/libva-intel-media-driver/Manifest b/media-libs/libva-intel-media-driver/Manifest
index ff9f9126e2c8..291a992583b6 100644
--- a/media-libs/libva-intel-media-driver/Manifest
+++ b/media-libs/libva-intel-media-driver/Manifest
@@ -1,2 +1,3 @@
DIST intel-media-23.3.5.tar.gz 28684285 BLAKE2B a552c86e3993476a2cef1e2c3faec0776d3c2bc3e329a5056786c9a80b1b066cbd05b7045854e237be2987e079123687826a7902050e8287ea2c2dc9ac2cd2dd SHA512 35565cbda85e0e2cadd272e164b59119d1e29938fd9cf0914f893aa87fd16864c19760e2e53f557f79c9688dc45aa26ccbfa4c4f4cd415ddb8db635f02f55b48
DIST intel-media-23.4.1.tar.gz 25748094 BLAKE2B b34dd342e1066775edc1de7bac0dc2a2fb04b12819bbc2c1d85a923c42e12d4b6af2fca6c8f6a80a962c6aeb7b3f0aa197eedd5c114180fe283c494586147e6d SHA512 ac15f2ce828bd5b1c1d6ca1e0e390360c9e65359d6dfe9384482d4ba56766f929a6092f14008d29c67622d976b027a4e125d7e88f9e8c054af1199398c2b29fd
+DIST intel-media-23.4.3.tar.gz 25805389 BLAKE2B ecb766bc3316e7cda338cc0b279ee31455596d004c11282dd1cad94f85f36c7711077648ae78c9b24e02198f8cc00746161fef119b86b10da52ddb2bf2949de5 SHA512 f28967d5474d43878ce6bf3e793c1a129fa0cd0240a2478d5d56ceb1fba3171ee8389c328818d90f914cabdd26caf1e7185dc9b38cd911a799b1fe2d8bc1ddfb
diff --git a/media-libs/libva-intel-media-driver/libva-intel-media-driver-23.4.3.ebuild b/media-libs/libva-intel-media-driver/libva-intel-media-driver-23.4.3.ebuild
new file mode 100644
index 000000000000..0fc271a25f62
--- /dev/null
+++ b/media-libs/libva-intel-media-driver/libva-intel-media-driver-23.4.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/media-driver"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ MY_PV="${PV%_pre}"
+ SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz"
+ S="${WORKDIR}/media-driver-intel-media-${MY_PV}"
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~amd64"
+ fi
+fi
+
+DESCRIPTION="Intel Media Driver for VA-API (iHD)"
+HOMEPAGE="https://github.com/intel/media-driver"
+
+LICENSE="MIT BSD redistributable? ( no-source-code )"
+SLOT="0"
+IUSE="+redistributable test X"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=media-libs/gmmlib-22.3.14:=[${MULTILIB_USEDEP}]
+ >=media-libs/libva-2.20.0[X?,${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.3.4-Remove-unwanted-CFLAGS.patch
+ "${FILESDIR}"/${PN}-23.3.4_testing_in_src_test.patch
+)
+
+multilib_src_configure() {
+ # https://github.com/intel/media-driver/issues/356
+ append-cxxflags -D_FILE_OFFSET_BITS=64
+
+ local mycmakeargs=(
+ -DMEDIA_BUILD_FATAL_WARNINGS=OFF
+ -DMEDIA_RUN_TEST_SUITE=$(usex test)
+ -DBUILD_TYPE=Release
+ -DPLATFORM=linux
+ -DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X)
+ -DENABLE_NONFREE_KERNELS=$(usex redistributable)
+ -DLATEST_CPP_NEEDED=ON # Seems to be the best option for now
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}