summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-02 21:41:22 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-02 21:41:39 +0100
commit0e88b50e735df339e4493f512c5e8178f9ffa1f4 (patch)
tree9c5cb39ba81b80e2a6f8fbfae0a3ff70d5c90523 /media-libs
parentgames-kids/gcompris: 1.0 version bump (diff)
downloadgentoo-0e88b50e735df339e4493f512c5e8178f9ffa1f4.tar.gz
gentoo-0e88b50e735df339e4493f512c5e8178f9ffa1f4.tar.bz2
gentoo-0e88b50e735df339e4493f512c5e8178f9ffa1f4.zip
media-libs/harfbuzz: Fixed python script shebangs
Closes: https://bugs.gentoo.org/762415 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.7.4.ebuild12
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild14
2 files changed, 19 insertions, 7 deletions
diff --git a/media-libs/harfbuzz/harfbuzz-2.7.4.ebuild b/media-libs/harfbuzz/harfbuzz-2.7.4.ebuild
index 89e06e272b90..19566a5b8ed7 100644
--- a/media-libs/harfbuzz/harfbuzz-2.7.4.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-2.7.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit flag-o-matic meson multilib-minimal python-any-r1 xdg-utils
@@ -44,7 +44,7 @@ BDEPEND="
"
pkg_setup() {
- use test && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
if ! use debug ; then
append-cppflags -DHB_NDEBUG
fi
@@ -62,6 +62,12 @@ src_prepare() {
# bug 618772
append-cxxflags -std=c++14
+
+ # bug 762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
}
meson_multilib_native_feature() {
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index d8d692333627..19566a5b8ed7 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit flag-o-matic meson multilib-minimal python-any-r1 xdg-utils
@@ -15,7 +15,7 @@ if [[ ${PV} = 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="Old-MIT ISC icu"
@@ -44,7 +44,7 @@ BDEPEND="
"
pkg_setup() {
- use test && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
if ! use debug ; then
append-cppflags -DHB_NDEBUG
fi
@@ -62,6 +62,12 @@ src_prepare() {
# bug 618772
append-cxxflags -std=c++14
+
+ # bug 762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
}
meson_multilib_native_feature() {