summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-01 14:29:17 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-01 14:49:41 -0500
commit46b2f0ab301a02e8763e461140b317e6dcd707bc (patch)
treede1806652997fe3f55a4ca333d633e89f8e2e05c /media-libs
parentprofiles: Add VIDEO_CARDS=swrast description (diff)
downloadgentoo-46b2f0ab301a02e8763e461140b317e6dcd707bc.tar.gz
gentoo-46b2f0ab301a02e8763e461140b317e6dcd707bc.tar.bz2
gentoo-46b2f0ab301a02e8763e461140b317e6dcd707bc.zip
media-libs/mesa: Add VIDEO_CARDS=swrast
Replaces VIDEO_CARDS=lavapipe; controls building the swrast/llvmpipe driver for OpenGL as well as the lavapipe driver for Vulkan. Closes: https://bugs.gentoo.org/920752 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index a7d485533118..69bb2e2a8abb 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -25,7 +25,7 @@ SLOT="0"
RESTRICT="!test? ( test )"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel swrast lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -47,8 +47,9 @@ REQUIRED_USE="
video_cards_vmware
)
)
+ osmesa? ( video_cards_swrast )
vulkan-overlay? ( vulkan )
- video_cards_lavapipe? ( llvm vulkan )
+ video_cards_swrast? ( vulkan? ( llvm ) )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
vdpau? ( X )
@@ -339,7 +340,7 @@ multilib_src_configure() {
gallium_enable -- kmsro
fi
- gallium_enable -- swrast
+ gallium_enable video_cards_swrast swrast
gallium_enable video_cards_freedreno freedreno
gallium_enable video_cards_intel crocus i915 iris
gallium_enable video_cards_lima lima
@@ -371,7 +372,7 @@ multilib_src_configure() {
fi
if use vulkan; then
- vulkan_enable video_cards_lavapipe swrast
+ vulkan_enable video_cards_swrast swrast
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel intel_hasvk
vulkan_enable video_cards_d3d12 microsoft-experimental