summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:59:16 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:59:16 +0200
commitc3cd2bb694eb1fa30fe5697846a5311ec0426be3 (patch)
tree151184b1453d1b30e36dad76c9e1df773764d518 /media-libs
parentmedia-libs/resid: drop multilib (diff)
downloadgentoo-c3cd2bb694eb1fa30fe5697846a5311ec0426be3.tar.gz
gentoo-c3cd2bb694eb1fa30fe5697846a5311ec0426be3.tar.bz2
gentoo-c3cd2bb694eb1fa30fe5697846a5311ec0426be3.zip
media-libs/theoraplay: drop multilib
No multilib reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/theoraplay/theoraplay-0_pre20180524-r1.ebuild (renamed from media-libs/theoraplay/theoraplay-0_pre20180524.ebuild)25
1 files changed, 12 insertions, 13 deletions
diff --git a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild b/media-libs/theoraplay/theoraplay-0_pre20180524-r1.ebuild
index 487a8f89eb15..dd50e14aae72 100644
--- a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
+++ b/media-libs/theoraplay/theoraplay-0_pre20180524-r1.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit multilib multilib-minimal toolchain-funcs
+inherit edo multilib toolchain-funcs
COMMIT="7d8701876294"
DESCRIPTION="Simple library to make decoding of Ogg Theora videos easier"
HOMEPAGE="https://icculus.org/projects/theoraplay/"
SRC_URI="https://hg.icculus.org/icculus/${PN}/archive/${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -18,19 +20,16 @@ RDEPEND="
media-libs/libtheora
media-libs/libvorbis
"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/libtool"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-multilib_src_compile() {
- libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c || die
- libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
- -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" || die
+src_compile() {
+ edo libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c
+ edo libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
+ -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)"
}
-multilib_src_install() {
+src_install() {
dolib.so .libs/lib${PN}$(get_libname)*
-}
-
-multilib_src_install_all() {
doheader ${PN}.h
}