summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2023-07-03 00:47:03 +0200
committerSam James <sam@gentoo.org>2023-07-16 19:42:15 +0100
commitc6b28aa3314bef445a8144cb01bc3cbad4d59f00 (patch)
tree63c16f93997b218ee85d479eface0149ff0fd8ae /media-libs
parentmedia-libs/openimageio: Version bump and fix compilation on arm64 (diff)
downloadgentoo-c6b28aa3314bef445a8144cb01bc3cbad4d59f00.tar.gz
gentoo-c6b28aa3314bef445a8144cb01bc3cbad4d59f00.tar.bz2
gentoo-c6b28aa3314bef445a8144cb01bc3cbad4d59f00.zip
media-libs/openpgl: Fix compiling with arm64 NEON
Closes: https://bugs.gentoo.org/908869 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openpgl/openpgl-0.5.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-libs/openpgl/openpgl-0.5.0.ebuild b/media-libs/openpgl/openpgl-0.5.0.ebuild
index 67870a6bfa63..02987ca560ce 100644
--- a/media-libs/openpgl/openpgl-0.5.0.ebuild
+++ b/media-libs/openpgl/openpgl-0.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Intel Open Path Guiding Library"
HOMEPAGE="https://github.com/OpenPathGuidingLibrary/openpgl"
@@ -33,6 +33,9 @@ src_configure() {
-DOPENPGL_ISA_NEON=$(usex cpu_flags_arm_neon)
)
+ # This is currently needed on arm64 to get the NEON SIMD wrapper to compile the code successfully
+ use cpu_flags_arm_neon && append-flags -flax-vector-conversions
+
# Disable asserts
append-cppflags $(usex debug '' '-DNDEBUG')