summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 04:34:07 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:18:26 +0100
commitc86aad600713909bf09a46ff9dba170c9b16df36 (patch)
tree28454d0f4d3e909e551486a8e09ac70d80f0baea /media-libs
parentdev-ros/urg_node: move CMAKE_MAKEFILE_GENERATOR to pre-inherit (diff)
downloadgentoo-c86aad600713909bf09a46ff9dba170c9b16df36.tar.gz
gentoo-c86aad600713909bf09a46ff9dba170c9b16df36.tar.bz2
gentoo-c86aad600713909bf09a46ff9dba170c9b16df36.zip
media-libs/libsdl: disable (some) broken features on Darwin
We can't get all the way there, but some features can't be built right now for sure, so let's disable those. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/libsdl-1.2.15_p20210224.ebuild24
1 files changed, 23 insertions, 1 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.15_p20210224.ebuild b/media-libs/libsdl/libsdl-1.2.15_p20210224.ebuild
index 4b61e3b581fd..65181ee97dc5 100644
--- a/media-libs/libsdl/libsdl-1.2.15_p20210224.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.15_p20210224.ebuild
@@ -74,11 +74,34 @@ HTML_DOCS=( {docs,VisualC}.html docs/{html,images,index.html} )
src_prepare() {
default
+
+ if $(tc-is-gcc) && [[ ${CHOST} == *-darwin* ]] ; then
+ # GCC at least has no idea what -fpascal-strings is
+ sed -i -e '/EXTRA_CFLAGS="$EXTRA_CFLAGS -fpascal-strings"/d' configure.ac || die
+ # We have trouble building against Frameworks with GCC for now (no Blocks support, etc)
+ # error: unknown type name ‘CGImageSourceAnimationBlock’
+ sed -i \
+ -e '/EXTRA_CFLAGS="$EXTRA_CFLAGS -DTARGET_API_MAC_CARBON"/d' \
+ -e '/EXTRA_CFLAGS="$EXTRA_CFLAGS -DTARGET_API_MAC_OSX"/d' \
+ configure.ac || die
+ fi
+
AT_M4DIR="${EPREFIX}/usr/share/aclocal acinclude" eautoreconf
}
multilib_src_configure() {
local myconf=
+
+ if $(tc-is-gcc) && [[ ${CHOST} == *-darwin* ]] ; then
+ # We can't build against Cocoa because we lack Blocks + Objective C++ support in
+ # GCC (for now)
+ use video && myconf="${myconf} --disable-video-cocoa"
+ # CD support drags in audio
+ myconf="${myconf} --disable-cdrom"
+ else
+ myconf="${myconf} --enable-cdrom"
+ fi
+
if use !x86 && use !x86-linux ; then
myconf="${myconf} --disable-nasm"
else
@@ -96,7 +119,6 @@ multilib_src_configure() {
--disable-arts \
--disable-esd \
--enable-events \
- --enable-cdrom \
--enable-threads \
--enable-timers \
--enable-file \