summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-13 13:00:56 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-13 13:03:09 -0400
commitf123e9823effa97371014375576f27efdede3928 (patch)
tree201e46603ed76dd8a6719bd5bbf919b19b4e1a68 /media-libs
parentgui-libs/wlroots: make session support optional based on libseat support (diff)
downloadgentoo-f123e9823effa97371014375576f27efdede3928.tar.gz
gentoo-f123e9823effa97371014375576f27efdede3928.tar.bz2
gentoo-f123e9823effa97371014375576f27efdede3928.zip
media-libs/mesa: Depend on libclc for Intel Vulkan
And limit it to amd64-only, since upstream only enables ray tracing for amd64. Closes: https://bugs.gentoo.org/906231 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-23.1.0.ebuild9
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-23.1.0.ebuild b/media-libs/mesa/mesa-23.1.0.ebuild
index 3e8e181feb85..33e29c1d3f7d 100644
--- a/media-libs/mesa/mesa-23.1.0.ebuild
+++ b/media-libs/mesa/mesa-23.1.0.ebuild
@@ -76,7 +76,14 @@ RDEPEND="
>=media-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
)
vdpau? ( >=x11-libs/libvdpau-1.1:=[${MULTILIB_USEDEP}] )
- vulkan? ( video_cards_intel? ( >=dev-util/spirv-tools-1.3.231.0 ) )
+ vulkan? (
+ video_cards_intel? (
+ amd64? (
+ dev-libs/libclc[spirv(-)]
+ >=dev-util/spirv-tools-1.3.231.0
+ )
+ )
+ )
selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.18.0[${MULTILIB_USEDEP}] )
${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_intel?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 1cafc813c908..2d73380b5ee3 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -76,7 +76,14 @@ RDEPEND="
>=media-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
)
vdpau? ( >=x11-libs/libvdpau-1.1:=[${MULTILIB_USEDEP}] )
- vulkan? ( video_cards_intel? ( >=dev-util/spirv-tools-1.3.231.0 ) )
+ vulkan? (
+ video_cards_intel? (
+ amd64? (
+ dev-libs/libclc[spirv(-)]
+ >=dev-util/spirv-tools-1.3.231.0
+ )
+ )
+ )
selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.18.0[${MULTILIB_USEDEP}] )
${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_intel?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]