summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-09-14 08:17:41 -0400
committerCraig Andrews <candrews@gentoo.org>2021-09-14 08:22:16 -0400
commit450d125395c3429c1fa7c41d0dd82cafda5b442a (patch)
treea41ecb8cd05c56ce41753a8545d512f49ee28af9 /media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-19.1.1.ebuild
parentwww-client/vivaldi-snapshot: Drop old 4.2.2406.4 (diff)
downloadgentoo-450d125395c3429c1fa7c41d0dd82cafda5b442a.tar.gz
gentoo-450d125395c3429c1fa7c41d0dd82cafda5b442a.tar.bz2
gentoo-450d125395c3429c1fa7c41d0dd82cafda5b442a.zip
media-plugins/kodi-visualization-shadertoy: 19.1.1 version bump
Closes: https://bugs.gentoo.org/813025 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-19.1.1.ebuild')
-rw-r--r--media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-19.1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-19.1.1.ebuild b/media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-19.1.1.ebuild
new file mode 100644
index 000000000000..df94a882ffaf
--- /dev/null
+++ b/media-plugins/kodi-visualization-shadertoy/kodi-visualization-shadertoy-19.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Shadertoy visualizer for Kodi"
+HOMEPAGE="https://github.com/xbmc/visualization.shadertoy"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/visualization.shadertoy.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/visualization.shadertoy/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/visualization.shadertoy-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ >=media-libs/glm-0.9.9.8-r1
+ virtual/opengl
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}