summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/qrq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/qrq')
-rw-r--r--media-radio/qrq/Manifest1
-rw-r--r--media-radio/qrq/metadata.xml8
-rw-r--r--media-radio/qrq/qrq-0.3.1.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/media-radio/qrq/Manifest b/media-radio/qrq/Manifest
new file mode 100644
index 000000000000..4a821032a7f6
--- /dev/null
+++ b/media-radio/qrq/Manifest
@@ -0,0 +1 @@
+DIST qrq-0.3.1.tar.gz 131508 SHA256 92988a33b7eddb3941cf91a285a57f4f0872722adf003350a8afe2caf83159a1 SHA512 ce6e3b6f79575f11457f56e1044267dbefda20b13ba43fd79b2ad5821b4502a8a2badacbd891e154472d6f26334a0a8fcddf9521d905d8e7a72d8a687346e23d WHIRLPOOL 8cdad3bebaf1754b499df1372acab50bbe24683f23ffeb337ca0a6d7379fea970f8ee5a8935b485f55f92b048459f284110fea0994c6327e659152a9a6129755
diff --git a/media-radio/qrq/metadata.xml b/media-radio/qrq/metadata.xml
new file mode 100644
index 000000000000..1500853ef050
--- /dev/null
+++ b/media-radio/qrq/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-radio/qrq/qrq-0.3.1.ebuild b/media-radio/qrq/qrq-0.3.1.ebuild
new file mode 100644
index 000000000000..cefc3258e02a
--- /dev/null
+++ b/media-radio/qrq/qrq-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Yet another CW trainer for Linux/Unix"
+HOMEPAGE="http://fkurz.net/ham/qrq.html"
+SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="pulseaudio"
+
+DEPEND="sys-libs/ncurses
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # avoid prestripping of 'qrq' binary
+ sed -i -e "s/install -s -m/install -m/" Makefile || die
+ sed -i -e "s/CC=gcc/CC=$(tc-getCC)/" Makefile || die
+ sed -i -e "s/-lpulse-simple/-lpthread -lpulse-simple/" Makefile || die
+}
+
+src_compile() {
+ CONF="USE_PA=NO USE_OSS=YES"
+ if use pulseaudio; then
+ CONF="USE_PA=YES USE_OSS=NO"
+ fi
+ emake $CONF
+}
+
+src_install() {
+ emake $CONF DESTDIR="${D}/usr" install
+ dodoc AUTHORS ChangeLog README
+}