summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2017-04-15 18:32:39 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2017-04-15 18:32:39 +0200
commit6003c12d8f04d506853f1554360c78abdf201c21 (patch)
tree163a18f7db64bbfb09fec8b9128284162618020c /media-radio/xwxapt/xwxapt-2.9.ebuild
parentkde-plasma/kwin: Drop 5.9.4 (r0) (diff)
downloadgentoo-6003c12d8f04d506853f1554360c78abdf201c21.tar.gz
gentoo-6003c12d8f04d506853f1554360c78abdf201c21.tar.bz2
gentoo-6003c12d8f04d506853f1554360c78abdf201c21.zip
media-radio/xwxapt: Version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-radio/xwxapt/xwxapt-2.9.ebuild')
-rw-r--r--media-radio/xwxapt/xwxapt-2.9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-radio/xwxapt/xwxapt-2.9.ebuild b/media-radio/xwxapt/xwxapt-2.9.ebuild
new file mode 100644
index 000000000000..40f26ed1177c
--- /dev/null
+++ b/media-radio/xwxapt/xwxapt-2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/apt.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-wireless/rtl-sdr
+ media-libs/alsa-lib
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # create missing mkinstalldir and prepare package
+ glib-gettextize --force --copy || die "gettextize failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+ dohtml doc/xwxapt.html
+ insinto /usr/share/${PN}
+ doins xwxapt/xwxaptrc
+ dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+ einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+ einfo "and configure the contained xwxaptrc file before starting the program"
+}