summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2025-01-09 17:47:02 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2025-01-09 17:51:36 +0100
commit4d81fabc9b02042bd82e850ef3b32ec5e1f078dc (patch)
treec578ceaa8a9b89a070db8ab668627f818acabfec /media-radio
parentdev-util/intel-graphics-compiler: update deps, drop comment (diff)
downloadgentoo-4d81fabc9b02042bd82e850ef3b32ec5e1f078dc.tar.gz
gentoo-4d81fabc9b02042bd82e850ef3b32ec5e1f078dc.tar.bz2
gentoo-4d81fabc9b02042bd82e850ef3b32ec5e1f078dc.zip
media-radio/qrq: Fix function declaration, bump EAPI
Closes: https://bugs.gentoo.org/947561 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/qrq/files/qrq-0.3.5-fix-missing-parms.patch26
-rw-r--r--media-radio/qrq/qrq-0.3.5-r2.ebuild44
2 files changed, 70 insertions, 0 deletions
diff --git a/media-radio/qrq/files/qrq-0.3.5-fix-missing-parms.patch b/media-radio/qrq/files/qrq-0.3.5-fix-missing-parms.patch
new file mode 100644
index 000000000000..415288dfeee2
--- /dev/null
+++ b/media-radio/qrq/files/qrq-0.3.5-fix-missing-parms.patch
@@ -0,0 +1,26 @@
+diff --git a/pulseaudio.c b/pulseaudio.c
+index 7a791a0..ee08dbb 100644
+--- a/pulseaudio.c
++++ b/pulseaudio.c
+@@ -33,7 +33,7 @@ short int *buf = 0;
+ int bufsize = 0;
+ int bufpos = 0;
+
+-void *open_dsp () {
++void *open_dsp (char *dummy) {
+ static int opened = 0;
+
+ /* with PA we only open the device once and then leave it
+diff --git a/pulseaudio.h b/pulseaudio.h
+index a915f88..fea4d0c 100644
+--- a/pulseaudio.h
++++ b/pulseaudio.h
+@@ -21,7 +21,7 @@ Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ #ifndef QRQ_PA
+ #define QRQ_PA
+
+-void *open_dsp ();
++void *open_dsp (char *dummy);
+ void write_audio (void *unused, int *in, int size);
+ void close_audio (void *s);
+
diff --git a/media-radio/qrq/qrq-0.3.5-r2.ebuild b/media-radio/qrq/qrq-0.3.5-r2.ebuild
new file mode 100644
index 000000000000..133c4e75a9eb
--- /dev/null
+++ b/media-radio/qrq/qrq-0.3.5-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Yet another CW trainer for Linux/Unix"
+HOMEPAGE="http://fkurz.net/ham/qrq.html"
+SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pulseaudio"
+
+DEPEND="sys-libs/ncurses:=
+ pulseaudio? ( media-libs/libpulse )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-0.3.2-tinfo.patch"
+ # bug #947561
+ "${FILESDIR}/${PN}-0.3.5-fix-missing-parms.patch" )
+
+src_prepare() {
+ # avoid prestripping of 'qrq' binary
+ sed -i -e "s/INSTALL} -s -m/INSTALL} -m/" Makefile || die
+ sed -i -e "s/CC=gcc/CC=$(tc-getCC)/" Makefile || die
+ default
+}
+
+src_compile() {
+ CONF="USE_PA=NO USE_OSS=YES"
+ if use pulseaudio; then
+ CONF="USE_PA=YES USE_OSS=NO"
+ fi
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)" ${CONF}
+}
+
+src_install() {
+ emake ${CONF} DESTDIR="${D}/usr" install
+ dodoc AUTHORS ChangeLog README
+}