summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/chordii
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/chordii')
-rw-r--r--media-sound/chordii/Manifest4
-rw-r--r--media-sound/chordii/chordii-4.3.ebuild37
-rw-r--r--media-sound/chordii/chordii-4.5.1.ebuild27
-rw-r--r--media-sound/chordii/metadata.xml31
4 files changed, 99 insertions, 0 deletions
diff --git a/media-sound/chordii/Manifest b/media-sound/chordii/Manifest
new file mode 100644
index 000000000000..e8af92164e34
--- /dev/null
+++ b/media-sound/chordii/Manifest
@@ -0,0 +1,4 @@
+DIST chordii-4.3-user_guide.pdf 1086988 SHA256 2b48651fa1c55088f7886e69ef4517f22100731fe5a69f8d65047537964b397d
+DIST chordii-4.3.tar.gz 151370 SHA256 49258c625aee42b400ca40252cc562ab0db4514c838de4545cbdbcfdcd77a302
+DIST chordii-4.5.1.tar.gz 156976 SHA256 16a3fe92a82ca734cb6d08a573e513510acd41d4020a6306ac3769f6af5aa08d SHA512 92996893417cfecb3cc18db283f2f608721172540f1fbb9ea300a0235fa99228a89d2c65417e8ddee91453d4bc12190d1504039e9689ed28ca863546fa938088 WHIRLPOOL a935ab83731da23c9aef5fffb8a15070ed341fd8db69ef9e108b2c07cdaafdbe96fc415b21a8473397d0456af6b20f5fbe314b5433618c79e782788a059ef80b
+DIST user_guide-4.5.pdf 389353 SHA256 b103e4da20c0f2af52ca9f7d34dfa75b7bd5c5da169ff395443c0029673fbf56 SHA512 9ad15cf89ae6790f59d4a224367d1b5d8ffb0aec04f217875d9f31477751046e22ab7f90f798ce2347d7dc781bcdf1665323cd315ad1148d600d5e5bf27ee096 WHIRLPOOL d050b8811f6c3cff2f6460b1a78c8d1a821df0058e49cb9f694e6c654a1569ff0a21ebc2d8b006f2d322e1b637bc5e15c9251a74037b93059a1a46ff55784032
diff --git a/media-sound/chordii/chordii-4.3.ebuild b/media-sound/chordii/chordii-4.3.ebuild
new file mode 100644
index 000000000000..d2f6ff66cebd
--- /dev/null
+++ b/media-sound/chordii/chordii-4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="A guitar music typesetter"
+HOMEPAGE="http://chordii.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${P}-user_guide.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND=">=sys-devel/autoconf-2.67"
+
+src_prepare() {
+ sed -i -e "/dist_man_MAN/d" man/Makefile.am
+ eautomake
+}
+
+src_install() {
+ default
+
+ use doc && dodoc "${DISTDIR}"/${P}-user_guide.pdf
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/media-sound/chordii/chordii-4.5.1.ebuild b/media-sound/chordii/chordii-4.5.1.ebuild
new file mode 100644
index 000000000000..a07b78b9d15e
--- /dev/null
+++ b/media-sound/chordii/chordii-4.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A guitar music typesetter"
+HOMEPAGE="http://chordii.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/user_guide-4.5.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_install() {
+ default
+
+ use doc && dodoc "${DISTDIR}"/user_guide-4.5.pdf
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/media-sound/chordii/metadata.xml b/media-sound/chordii/metadata.xml
new file mode 100644
index 000000000000..c1cc2cbeaab8
--- /dev/null
+++ b/media-sound/chordii/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ Chordii is a fork of Chord, a program very popular several years
+ ago and most famous for its trendsetting 'ChordPro' music file format.
+
+ Chordii's purpose is to provide guitar players with a tool to produce
+ good looking, self-descriptive music sheets from text files.
+
+ Chordii reads a text file containing the lyrics of a song, the chords
+ to be played, their description and some other optional data to
+ produce a PostScript document that includes:
+
+ * Centered titles
+ * Chord names above the words
+ * Graphical representation of the chords at the end of the songs
+ * Transposition
+ * Multiple columns on a page
+ * Index of a songbook
+ * Multiple logical pages per physical pages (1, 2 or 4)
+ * Configurable fonts for the lyrics and the chord names
+ * Multiple songs inside one file
+ * The complete ISO 8859-1 character set
+ * Chorus marking
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">chordii</remote-id>
+ </upstream>
+</pkgmetadata>