summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2024-04-18 00:31:15 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2024-04-18 09:46:38 +0200
commite29a900dbc7617552d88dd76008c0f3539c00910 (patch)
tree966e5fad686fc94a82ebfa52281c0000a64b3057 /media-sound/guitarix
parentwww-servers/tomcat: add bnd-annotation to runtime-classpath (diff)
downloadgentoo-e29a900dbc7617552d88dd76008c0f3539c00910.tar.gz
gentoo-e29a900dbc7617552d88dd76008c0f3539c00910.tar.bz2
gentoo-e29a900dbc7617552d88dd76008c0f3539c00910.zip
media-sound/guitarix: Version bump to 0.46.0
Closes: https://bugs.gentoo.org/926899 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/36299 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/Manifest1
-rw-r--r--media-sound/guitarix/files/guitarix-0.46.0-nostrip.patch30
-rw-r--r--media-sound/guitarix/guitarix-0.46.0.ebuild92
3 files changed, 123 insertions, 0 deletions
diff --git a/media-sound/guitarix/Manifest b/media-sound/guitarix/Manifest
index e367b57bdbcb..6389e2a32b17 100644
--- a/media-sound/guitarix/Manifest
+++ b/media-sound/guitarix/Manifest
@@ -1 +1,2 @@
DIST guitarix2-0.45.0.tar.xz 75575216 BLAKE2B dfe65b3cdab6cf30c808b65d4d9280617d5b9b9d0227bb6b60b68ac52e64fb34903fdfb3084ebf790630b60a54cfd1f0b170b209b8dfb5c0f23f1d8084e3c342 SHA512 be894076f5b016cb8feb243294e8277f893f7e7054c91353f1a82e9b41ef1bc8c97714c4b6cf9765ee6ab1cff91d02f3a0abe525985922dcde788011a88b9cf4
+DIST guitarix2-0.46.0.tar.xz 77670776 BLAKE2B b650d53f4e73539419bbe194e07ee770494f80b547d407f5a269c035b91fbf3e0fe078a9e82da21f773d69395523f70fc179be7942f08e2b8689b220414c9925 SHA512 cdb8eccdd230bade493cf0b7fd2a6e748fcaf3c3fd6b5ed5fbd6134d08be9518c93400625d63e386b436fcef3e1738cae543256b09941445436d7f2bf41649a0
diff --git a/media-sound/guitarix/files/guitarix-0.46.0-nostrip.patch b/media-sound/guitarix/files/guitarix-0.46.0-nostrip.patch
new file mode 100644
index 000000000000..7bb46c88eb16
--- /dev/null
+++ b/media-sound/guitarix/files/guitarix-0.46.0-nostrip.patch
@@ -0,0 +1,30 @@
+--- a/waftools/lv2.py
++++ b/waftools/lv2.py
+@@ -40,7 +40,7 @@ def lv2_add_common(tg, target, install_path, defines=None, linkflags=None, cxxfl
+ @Configure.conf
+ def lv2(bld, *k, **kw):
+ lv2_base, dst = get_lv2_base(bld, kw)
+- tg = bld.shlib(features='strip', *k, **kw)
++ tg = bld.shlib(*k, **kw)
+ cxxflags = []
+ if not bld.env['OPT'] and bld.env['SSE2']:
+ cxxflags = [ "-msse2", "-mfpmath=sse"]
+@@ -57,7 +57,7 @@ def lv2_gui(bld, *k, **kw):
+ if not bld.env['LV2GUI']:
+ return None
+ lv2_base, dst = get_lv2_base(bld, kw)
+- tg = bld.shlib(features='strip', *k, **kw)
++ tg = bld.shlib(*k, **kw)
+ lv2_add_common(tg, lv2_base+'_gui', dst, ["LV2_GUI"], bld.env['OS_LV2_CXXFLAGS'])
+ return tg
+
+--- a/wscript
++++ b/wscript
+@@ -404,7 +404,6 @@ def configure(conf):
+ conf.env['DESKAPPS_DIR'] = os.path.normpath(os.path.join(conf.env['SHAREDIR'], 'applications'))
+ conf.env['BIN_NAME'] = APPNAME
+ if opt.lv2:
+- conf.gxload('strip')
+ conf.gxload('lv2')
+
+ conf.gxload('cpu_optimization')
diff --git a/media-sound/guitarix/guitarix-0.46.0.ebuild b/media-sound/guitarix/guitarix-0.46.0.ebuild
new file mode 100644
index 000000000000..bd63bf337a24
--- /dev/null
+++ b/media-sound/guitarix/guitarix-0.46.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit multiprocessing python-any-r1 waf-utils xdg
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="https://guitarix.org/"
+SRC_URI="https://github.com/brummer10/${PN}/releases/download/V${PV}/guitarix2-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bluetooth debug lv2 nls nsm +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ media-libs/libsndfile
+ media-libs/zita-convolver:=
+ media-libs/zita-resampler
+ net-misc/curl
+ sci-libs/fftw:3.0=
+ x11-libs/gtk+:3
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ nsm? ( media-libs/liblo )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# roboto fonts are required for correct ui rendering
+RDEPEND="
+ ${DEPEND}
+ standalone? (
+ media-fonts/roboto
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ standalone? (
+ dev-lang/sassc
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ )
+"
+
+DOCS=( changelog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.46.0-nostrip.patch
+)
+
+src_configure() {
+ export -n {CXX,LD}FLAGS
+
+ local myconf=(
+ --cxxflags="${CXXFLAGS}"
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ --jobs=$(makeopts_jobs)
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex nsm "" "--no-nsm")
+ $(usex standalone "" "--no-standalone")
+ $(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
+}