summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2016-12-11 22:06:05 +0100
committerMichał Górny <mgorny@gentoo.org>2016-12-12 20:41:08 +0100
commit8d0bc209760320e8c9f9fe55f95f815a510173fb (patch)
tree645a2407aaa41b208687d95f4b22daeaca0f8368 /media-sound/lilypond/lilypond-9999.ebuild
parentapp-emulation/hercules: version bump to 3.12 (diff)
downloadgentoo-8d0bc209760320e8c9f9fe55f95f815a510173fb.tar.gz
gentoo-8d0bc209760320e8c9f9fe55f95f815a510173fb.tar.bz2
gentoo-8d0bc209760320e8c9f9fe55f95f815a510173fb.zip
media-sound/lilypond: Fix bug #586592, correct guile deps, remove old
Closes: https://github.com/gentoo/gentoo/pull/3062 Package-Manager: portage-2.3.3
Diffstat (limited to 'media-sound/lilypond/lilypond-9999.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 63535e73399f..4326beff0071 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
[[ "${PV}" = "9999" ]] && inherit git-r3
-inherit elisp-common autotools python-single-r1
+inherit elisp-common autotools python-single-r1 xdg-utils
if [[ "${PV}" = "9999" ]]; then
EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
@@ -21,7 +21,7 @@ HOMEPAGE="http://lilypond.org/"
LICENSE="GPL-3 FDL-1.3"
SLOT="0"
LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
-IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
+IUSE="debug emacs guile2 profile vim-syntax ${LANGS// / linguas_}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND=">=app-text/ghostscript-gpl-8.15
@@ -31,6 +31,11 @@ RDEPEND=">=app-text/ghostscript-gpl-8.15
media-libs/freetype:2
>=x11-libs/pango-1.12.3
emacs? ( virtual/emacs )
+ guile2? ( >=dev-scheme/guile-2:12 )
+ !guile2? (
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ <dev-scheme/guile-2.0:12
+ )
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
app-text/t1utils
@@ -87,6 +92,8 @@ src_prepare() {
rm tex/texinfo.tex || die
eautoreconf
+
+ xdg_environment_reset #586592
}
src_configure() {
@@ -99,11 +106,10 @@ src_configure() {
--disable-optimising
--disable-pipe
$(use_enable debug debugging)
+ $(use_enable guile2)
$(use_enable profile profiling)
)
- has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
-
econf "${myeconfargs[@]}"
}