summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-22 00:48:15 +0100
committerSam James <sam@gentoo.org>2023-07-22 00:48:15 +0100
commit3b4a33610c0cb89957719308e5375d8a4a151755 (patch)
tree2c8ec95e573296e67684153cccfd8a2445454d2b /media-sound/lmms
parentsys-devel/gcc: add 12.3.1_p20230721 (diff)
downloadgentoo-3b4a33610c0cb89957719308e5375d8a4a151755.tar.gz
gentoo-3b4a33610c0cb89957719308e5375d8a4a151755.tar.bz2
gentoo-3b4a33610c0cb89957719308e5375d8a4a151755.zip
media-sound/lmms: fix ladspa plugin paths
Bug: https://github.com/LMMS/lmms/issues/5884 Closes: https://bugs.gentoo.org/907285 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/Manifest1
-rw-r--r--media-sound/lmms/files/lmms-1.2.2-plugin-path.patch26
-rw-r--r--media-sound/lmms/files/lmms-9999-no_compress_man.patch48
-rw-r--r--media-sound/lmms/files/lmms-9999-plugin-path.patch26
-rw-r--r--media-sound/lmms/lmms-1.2.2-r1.ebuild100
-rw-r--r--media-sound/lmms/lmms-9999.ebuild19
6 files changed, 212 insertions, 8 deletions
diff --git a/media-sound/lmms/Manifest b/media-sound/lmms/Manifest
index 16f24a2a4c61..f2ed22466b75 100644
--- a/media-sound/lmms/Manifest
+++ b/media-sound/lmms/Manifest
@@ -1 +1,2 @@
DIST lmms-1.2.2.tar.xz 22733960 BLAKE2B 8b561068194e9a4af8260675e784c25a92b6b2f731c29b677cbc16581306bbadcf27ea529adbcd735ff4adffedf3dd98ec7b2d89428a63ea600d022ecdae58e4 SHA512 df74d9e938f1c3807e9941b11db4ccfe9450e23b723c82774de15b7666ac39f1bfdd8519231e28849f994628190ecc92fa05d55bbc0b50a4421f2d183e729028
+DIST lmms_1.2.2.tar.xz 22733960 BLAKE2B 8b561068194e9a4af8260675e784c25a92b6b2f731c29b677cbc16581306bbadcf27ea529adbcd735ff4adffedf3dd98ec7b2d89428a63ea600d022ecdae58e4 SHA512 df74d9e938f1c3807e9941b11db4ccfe9450e23b723c82774de15b7666ac39f1bfdd8519231e28849f994628190ecc92fa05d55bbc0b50a4421f2d183e729028
diff --git a/media-sound/lmms/files/lmms-1.2.2-plugin-path.patch b/media-sound/lmms/files/lmms-1.2.2-plugin-path.patch
new file mode 100644
index 000000000000..0fabfbb89a30
--- /dev/null
+++ b/media-sound/lmms/files/lmms-1.2.2-plugin-path.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/907285
+https://github.com/LMMS/lmms/issues/5884
+https://src.fedoraproject.org/rpms/lmms/blob/rawhide/f/lmms-1.2.2_lib_suffix.patch
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -564,6 +564,9 @@ IF(USE_CCACHE)
+ ENDIF()
+ ENDIF()
+
++# pass LIB_SUFFIX
++add_definitions(-DLIB_SUFFIX="${LIB_SUFFIX}")
++
+ # make sub-directories
+ ADD_SUBDIRECTORY(cmake)
+ ADD_SUBDIRECTORY(src)
+--- a/src/core/PluginFactory.cpp
++++ b/src/core/PluginFactory.cpp
+@@ -64,7 +64,7 @@ PluginFactory::PluginFactory()
+ // plugins at "C:/Program Files/LMMS/plugins/"
+
+ #ifndef LMMS_BUILD_WIN32
+- addRelativeIfExists("../lib/lmms"); // Installed
++ addRelativeIfExists("../lib" LIB_SUFFIX "/lmms"); // Installed
+ #endif
+ addRelativeIfExists("plugins"); // Portable
+ #ifdef PLUGIN_DIR // We may also have received a relative directory via a define
diff --git a/media-sound/lmms/files/lmms-9999-no_compress_man.patch b/media-sound/lmms/files/lmms-9999-no_compress_man.patch
new file mode 100644
index 000000000000..e6db189f50ed
--- /dev/null
+++ b/media-sound/lmms/files/lmms-9999-no_compress_man.patch
@@ -0,0 +1,48 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -669,7 +669,7 @@ ADD_SUBDIRECTORY(doc)
+ ADD_SUBDIRECTORY(cmake/install)
+
+ FIND_PACKAGE(UnixCommands)
+-IF(GZIP)
++IF(FALSE)
+ ADD_CUSTOM_COMMAND(OUTPUT "${CMAKE_BINARY_DIR}/lmms.1.gz"
+ COMMAND ${GZIP} -c ${CMAKE_SOURCE_DIR}/doc/lmms.1 > ${CMAKE_BINARY_DIR}/lmms.1.gz
+ DEPENDS "${CMAKE_SOURCE_DIR}/doc/lmms.1"
+@@ -680,7 +680,6 @@ IF(GZIP)
+ ADD_CUSTOM_TARGET(manpage ALL
+ DEPENDS "${CMAKE_BINARY_DIR}/lmms.1.gz")
+ ELSEIF(UNIX)
+- MESSAGE(FATAL_ERROR "Can't find gzip required for generating lmms.1.gz")
+ ENDIF()
+
+ # install headers
+@@ -698,7 +697,7 @@ ENDIF(LMMS_BUILD_LINUX)
+ #
+ ADD_CUSTOM_TARGET(distclean
+ COMMAND make clean
+- COMMAND rm -rf `find -name cmake_install.cmake` `find -name Makefile` `find -type d -name CMakeFiles` CMakeCache.txt lmmsconfig.h lmms.1.gz)
++ COMMAND rm -rf `find -name cmake_install.cmake` `find -name Makefile` `find -type d -name CMakeFiles` CMakeCache.txt lmmsconfig.h lmms.1)
+
+ #
+ # add tarball-target
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -140,7 +140,7 @@ IF(NOT CMAKE_VERSION VERSION_LESS 3.6)
+ SET_PROPERTY(DIRECTORY ${CMAKE_SOURCE_DIR} PROPERTY VS_STARTUP_PROJECT lmms)
+ ENDIF()
+
+-SET_DIRECTORY_PROPERTIES(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES "${LMMS_RCC_OUT} ${LMMS_UI_OUT} lmmsconfig.h lmms.1.gz")
++SET_DIRECTORY_PROPERTIES(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES "${LMMS_RCC_OUT} ${LMMS_UI_OUT} lmmsconfig.h lmms.1")
+
+ IF(LMMS_BUILD_WIN32)
+ SET(EXTRA_LIBRARIES "winmm")
+@@ -233,7 +233,7 @@ ELSE()
+ ELSE(CMAKE_INSTALL_MANDIR)
+ SET(INSTALL_MANDIR ${CMAKE_INSTALL_PREFIX}/share/man)
+ ENDIF(CMAKE_INSTALL_MANDIR)
+- INSTALL(FILES "${CMAKE_BINARY_DIR}/lmms.1.gz"
++ INSTALL(FILES "${CMAKE_SOURCE_DIR}/doc/lmms.1"
+ DESTINATION "${INSTALL_MANDIR}/man1/"
+ PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
+ ENDIF()
diff --git a/media-sound/lmms/files/lmms-9999-plugin-path.patch b/media-sound/lmms/files/lmms-9999-plugin-path.patch
new file mode 100644
index 000000000000..0d04bf8d3027
--- /dev/null
+++ b/media-sound/lmms/files/lmms-9999-plugin-path.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/907285
+https://github.com/LMMS/lmms/issues/5884
+https://src.fedoraproject.org/rpms/lmms/blob/rawhide/f/lmms-1.2.2_lib_suffix.patch
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -657,6 +657,9 @@ ENDIF()
+ # use ccache
+ include(CompileCache)
+
++# pass LIB_SUFFIX
++add_definitions(-DLIB_SUFFIX="${LIB_SUFFIX}")
++
+ # make sub-directories
+ ADD_SUBDIRECTORY(cmake)
+ ADD_SUBDIRECTORY(src)
+--- a/src/core/PluginFactory.cpp
++++ b/src/core/PluginFactory.cpp
+@@ -78,7 +78,7 @@ void PluginFactory::setupSearchPaths()
+ // plugins at "C:/Program Files/LMMS/plugins/"
+
+ #ifndef LMMS_BUILD_WIN32
+- addRelativeIfExists("../lib/lmms"); // Installed
++ addRelativeIfExists("../lib" LIB_SUFFIX "/lmms"); // Installed
+ #endif
+ addRelativeIfExists("plugins"); // Portable
+ #ifdef PLUGIN_DIR // We may also have received a relative directory via a define
diff --git a/media-sound/lmms/lmms-1.2.2-r1.ebuild b/media-sound/lmms/lmms-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..535760eee0c3
--- /dev/null
+++ b/media-sound/lmms/lmms-1.2.2-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Cross-platform music production software"
+HOMEPAGE="https://lmms.io"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/LMMS/lmms.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/LMMS/lmms/releases/download/v${PV/_/-}/${PN}_${PV/_/-}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${P/_/-}"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="alsa debug fluidsynth jack libgig mp3 ogg portaudio pulseaudio sdl soundio stk vst"
+
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/libsamplerate-0.1.8
+ >=media-libs/libsndfile-1.0.11
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ >=x11-libs/fltk-1.3.0_rc3:1
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth )
+ jack? ( virtual/jack )
+ libgig? ( media-libs/libgig )
+ mp3? ( media-sound/lame )
+ ogg? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-libs/libpulse )
+ sdl? (
+ media-libs/libsdl
+ >=media-libs/sdl-sound-1.0.1
+ )
+ soundio? ( media-libs/libsoundio )
+ stk? ( media-libs/stk )
+ vst? ( virtual/wine )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtx11extras:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/calf
+ media-plugins/caps-plugins
+ media-plugins/cmt-plugins
+ media-plugins/swh-plugins
+ media-plugins/tap-plugins
+"
+
+DOCS=( README.md doc/AUTHORS )
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.2-no_compress_man.patch" #733284
+ "${FILESDIR}/${PN}-1.2.2-plugin-path.patch" #907285
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_WERROR=FALSE
+ -DWANT_CAPS=FALSE
+ -DWANT_TAP=FALSE
+ -DWANT_SWH=FALSE
+ -DWANT_CMT=FALSE
+ -DWANT_CALF=FALSE
+ -DWANT_QT5=TRUE
+ -DWANT_ALSA=$(usex alsa)
+ -DWANT_JACK=$(usex jack)
+ -DWANT_GIG=$(usex libgig)
+ -DWANT_MP3LAME=$(usex mp3)
+ -DWANT_OGGVORBIS=$(usex ogg)
+ -DWANT_PORTAUDIO=$(usex portaudio)
+ -DWANT_PULSEAUDIO=$(usex pulseaudio)
+ -DWANT_SDL=$(usex sdl)
+ -DWANT_SOUNDIO=$(usex soundio)
+ -DWANT_STK=$(usex stk)
+ -DWANT_VST=$(usex vst)
+ -DWANT_SF2=$(usex fluidsynth)
+ )
+
+ cmake_src_configure
+}
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index 329eb0410291..f525286d2873 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# The order is important here! Both, cmake and xdg define src_prepare.
-# We need the one from cmake
-inherit bash-completion-r1 xdg cmake
+inherit cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -13,9 +11,9 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/LMMS/lmms.git"
inherit git-r3
else
- SRC_URI="https://github.com/LMMS/lmms/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
+ SRC_URI="https://github.com/LMMS/lmms/releases/download/v${PV/_/-}/${PN}_${PV/_/-}.tar.xz"
+ S="${WORKDIR}/${PN}"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${P/_/-}"
fi
LICENSE="GPL-2 LGPL-2"
@@ -68,9 +66,13 @@ RDEPEND="${COMMON_DEPEND}
DOCS=( README.md doc/AUTHORS )
+PATCHES=(
+ "${FILESDIR}/${PN}-9999-no_compress_man.patch" #733284
+ "${FILESDIR}/${PN}-9999-plugin-path.patch" #907285
+)
+
src_configure() {
- local mycmakeargs+=(
- -DBASHCOMP_PKG_PATH="$(get_bashcompdir)"
+ local mycmakeargs=(
-DUSE_WERROR=FALSE
-DWANT_CAPS=FALSE
-DWANT_TAP=FALSE
@@ -91,5 +93,6 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
+
cmake_src_configure
}