summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-24 22:57:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-24 23:47:56 +0100
commitd68b84ea00dcc1a0e29d99ce8c07d0c76a72e720 (patch)
tree4acf8a8b173f2e411aec1daa092d4da45fc70335 /media-sound/mixxx
parentwww-client/chromium: beta channel bump to 80.0.3987.66 (diff)
downloadgentoo-d68b84ea00dcc1a0e29d99ce8c07d0c76a72e720.tar.gz
gentoo-d68b84ea00dcc1a0e29d99ce8c07d0c76a72e720.tar.bz2
gentoo-d68b84ea00dcc1a0e29d99ce8c07d0c76a72e720.zip
media-sound/mixxx: Fix disappearing fader handles w/ Qt 5.14
Closes: https://bugs.gentoo.org/704176 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/mixxx')
-rw-r--r--media-sound/mixxx/files/mixxx-2.2.3-qt-5.14.patch215
-rw-r--r--media-sound/mixxx/mixxx-2.2.3-r1.ebuild138
2 files changed, 353 insertions, 0 deletions
diff --git a/media-sound/mixxx/files/mixxx-2.2.3-qt-5.14.patch b/media-sound/mixxx/files/mixxx-2.2.3-qt-5.14.patch
new file mode 100644
index 000000000000..686b16e159f0
--- /dev/null
+++ b/media-sound/mixxx/files/mixxx-2.2.3-qt-5.14.patch
@@ -0,0 +1,215 @@
+From e581b59fa838f471259ea24089d663bec4c02a1a Mon Sep 17 00:00:00 2001
+From: "S.Brandt" <s.brandt@mixxx.org>
+Date: Fri, 17 Jan 2020 13:03:58 +0100
+Subject: [PATCH 1/2] Fixes faders become invisible for the Deere skin with QT
+ 5.14.0 . Simplified the affected svg graphics. There was some transformation
+ going on (that rotates a shape around the point 0,0), also the unscaled
+ handle graphics were bigger than the slider graphics. That was apparently not
+ an issue pre-QT5.14.0.
+
+---
+ res/skins/Deere/handle-crossfader-blue.svg | 8 ++++++--
+ res/skins/Deere/handle-crossfader-grey.svg | 8 ++++++--
+ res/skins/Deere/handle-crossfader-lime.svg | 8 ++++++--
+ res/skins/Deere/handle-crossfader-orange.svg | 8 ++++++--
+ res/skins/Deere/handle-vertical-blue.svg | 8 ++++++--
+ res/skins/Deere/handle-vertical-carmine.svg | 8 ++++++--
+ res/skins/Deere/handle-vertical-grey.svg | 8 ++++++--
+ res/skins/Deere/handle-vertical-lime.svg | 8 ++++++--
+ res/skins/Deere/handle-vertical-orange.svg | 8 ++++++--
+ res/skins/Deere/handle-vertical-purple.svg | 8 ++++++--
+ res/skins/Deere/slider-crossfader-AutoDJ.svg | 6 +++++-
+ res/skins/Deere/slider-crossfader.svg | 8 ++++++--
+ res/skins/Deere/slider-vertical.svg | 8 ++++++--
+ 13 files changed, 77 insertions(+), 25 deletions(-)
+
+diff --git a/res/skins/Deere/handle-crossfader-blue.svg b/res/skins/Deere/handle-crossfader-blue.svg
+index d17d769ec93..673ab8c304f 100644
+--- a/res/skins/Deere/handle-crossfader-blue.svg
++++ b/res/skins/Deere/handle-crossfader-blue.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="80" height="200" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="scale(-1)" x="-75" y="-195" width="70" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="rotate(90)" x="22.134" y="-57.263" width="155.73" height="34.525" rx="2" ry="2" fill="#c5d11f"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="15" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m3 1h9c1.108 0 2 0.892 2 2v34c0 1.108-0.892 2-2 2h-9c-1.108 0-2-0.892-2-2v-34c0-1.108 0.892-2 2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m4 35.589v-31.178c0-0.22768 0.21148-0.41097 0.47417-0.41097h6.0517c0.26269 0 0.47417 0.18329 0.47417 0.41097v31.178c0 0.22768-0.21148 0.41097-0.47417 0.41097h-6.0517c-0.26269 0-0.47417-0.18329-0.47417-0.41097z" fill="#378df7"/>
++</svg>
+diff --git a/res/skins/Deere/handle-crossfader-grey.svg b/res/skins/Deere/handle-crossfader-grey.svg
+index 6c08871bae8..eb80ee8306e 100644
+--- a/res/skins/Deere/handle-crossfader-grey.svg
++++ b/res/skins/Deere/handle-crossfader-grey.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="80" height="200" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="scale(-1)" x="-75" y="-195" width="70" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="rotate(90)" x="22.134" y="-57.263" width="155.73" height="34.525" rx="2" ry="2" fill="#939393"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="15" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m3 1h9c1.108 0 2 0.892 2 2v34c0 1.108-0.892 2-2 2h-9c-1.108 0-2-0.892-2-2v-34c0-1.108 0.892-2 2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m4 35.589v-31.178c0-0.22768 0.21148-0.41097 0.47417-0.41097h6.0517c0.26269 0 0.47417 0.18329 0.47417 0.41097v31.178c0 0.22768-0.21148 0.41097-0.47417 0.41097h-6.0517c-0.26269 0-0.47417-0.18329-0.47417-0.41097z" fill="#939393"/>
++</svg>
+diff --git a/res/skins/Deere/handle-crossfader-lime.svg b/res/skins/Deere/handle-crossfader-lime.svg
+index d17d769ec93..581868854b1 100644
+--- a/res/skins/Deere/handle-crossfader-lime.svg
++++ b/res/skins/Deere/handle-crossfader-lime.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="80" height="200" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="scale(-1)" x="-75" y="-195" width="70" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="rotate(90)" x="22.134" y="-57.263" width="155.73" height="34.525" rx="2" ry="2" fill="#c5d11f"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="15" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m3 1h9c1.108 0 2 0.892 2 2v34c0 1.108-0.892 2-2 2h-9c-1.108 0-2-0.892-2-2v-34c0-1.108 0.892-2 2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m4 35.589v-31.178c0-0.22768 0.21148-0.41097 0.47417-0.41097h6.0517c0.26269 0 0.47417 0.18329 0.47417 0.41097v31.178c0 0.22768-0.21148 0.41097-0.47417 0.41097h-6.0517c-0.26269 0-0.47417-0.18329-0.47417-0.41097z" fill="#c5d11f"/>
++</svg>
+diff --git a/res/skins/Deere/handle-crossfader-orange.svg b/res/skins/Deere/handle-crossfader-orange.svg
+index c3587a775e1..15f2949153e 100644
+--- a/res/skins/Deere/handle-crossfader-orange.svg
++++ b/res/skins/Deere/handle-crossfader-orange.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="80" height="200" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="scale(-1)" x="-75" y="-195" width="70" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="rotate(90)" x="22.134" y="-57.263" width="155.73" height="34.525" rx="2" ry="2" fill="#ffb108"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="15" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m3 1h9c1.108 0 2 0.892 2 2v34c0 1.108-0.892 2-2 2h-9c-1.108 0-2-0.892-2-2v-34c0-1.108 0.892-2 2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m4 35.589v-31.178c0-0.22768 0.21148-0.41097 0.47417-0.41097h6.0517c0.26269 0 0.47417 0.18329 0.47417 0.41097v31.178c0 0.22768-0.21148 0.41097-0.47417 0.41097h-6.0517c-0.26269 0-0.47417-0.18329-0.47417-0.41097z" fill="#ffb108"/>
++</svg>
+diff --git a/res/skins/Deere/handle-vertical-blue.svg b/res/skins/Deere/handle-vertical-blue.svg
+index b12a90b8194..c595936fb43 100644
+--- a/res/skins/Deere/handle-vertical-blue.svg
++++ b/res/skins/Deere/handle-vertical-blue.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="200" height="75" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="rotate(-90)" x="-70" y="5" width="65" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#378df7"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="15" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m1 12v-9c0-1.108 0.892-2 2-2h34c1.108 0 2 0.892 2 2v9c0 1.108-0.892 2-2 2h-34c-1.108 0-2-0.892-2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m35.589 11h-31.178c-0.22768 0-0.41097-0.21148-0.41097-0.47417v-6.0517c0-0.26269 0.18329-0.47417 0.41097-0.47417h31.178c0.22768 0 0.41097 0.21148 0.41097 0.47417v6.0517c0 0.26269-0.18329 0.47417-0.41097 0.47417z" fill="#378df7"/>
++</svg>
+diff --git a/res/skins/Deere/handle-vertical-carmine.svg b/res/skins/Deere/handle-vertical-carmine.svg
+index 2ed243a60de..e1e700d8814 100644
+--- a/res/skins/Deere/handle-vertical-carmine.svg
++++ b/res/skins/Deere/handle-vertical-carmine.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="200" height="75" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="rotate(-90)" x="-70" y="5" width="65" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#e02f00"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="15" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m1 12v-9c0-1.108 0.892-2 2-2h34c1.108 0 2 0.892 2 2v9c0 1.108-0.892 2-2 2h-34c-1.108 0-2-0.892-2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m35.589 11h-31.178c-0.22768 0-0.41097-0.21148-0.41097-0.47417v-6.0517c0-0.26269 0.18329-0.47417 0.41097-0.47417h31.178c0.22768 0 0.41097 0.21148 0.41097 0.47417v6.0517c0 0.26269-0.18329 0.47417-0.41097 0.47417z" fill="#e02f00"/>
++</svg>
+diff --git a/res/skins/Deere/handle-vertical-grey.svg b/res/skins/Deere/handle-vertical-grey.svg
+index c93bbfdf0b8..3bc72218911 100644
+--- a/res/skins/Deere/handle-vertical-grey.svg
++++ b/res/skins/Deere/handle-vertical-grey.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="200" height="75" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="rotate(-90)" x="-70" y="5" width="65" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#939393"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="15" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m1 12v-9c0-1.108 0.892-2 2-2h34c1.108 0 2 0.892 2 2v9c0 1.108-0.892 2-2 2h-34c-1.108 0-2-0.892-2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m35.589 11h-31.178c-0.22768 0-0.41097-0.21148-0.41097-0.47417v-6.0517c0-0.26269 0.18329-0.47417 0.41097-0.47417h31.178c0.22768 0 0.41097 0.21148 0.41097 0.47417v6.0517c0 0.26269-0.18329 0.47417-0.41097 0.47417z" fill="#939393"/>
++</svg>
+diff --git a/res/skins/Deere/handle-vertical-lime.svg b/res/skins/Deere/handle-vertical-lime.svg
+index 5cd4d0c76bd..158d494d62a 100644
+--- a/res/skins/Deere/handle-vertical-lime.svg
++++ b/res/skins/Deere/handle-vertical-lime.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="200" height="75" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="rotate(-90)" x="-70" y="5" width="65" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#c5d11f"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="15" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m1 12v-9c0-1.108 0.892-2 2-2h34c1.108 0 2 0.892 2 2v9c0 1.108-0.892 2-2 2h-34c-1.108 0-2-0.892-2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m35.589 11h-31.178c-0.22768 0-0.41097-0.21148-0.41097-0.47417v-6.0517c0-0.26269 0.18329-0.47417 0.41097-0.47417h31.178c0.22768 0 0.41097 0.21148 0.41097 0.47417v6.0517c0 0.26269-0.18329 0.47417-0.41097 0.47417z" fill="#c5d11f"/>
++</svg>
+diff --git a/res/skins/Deere/handle-vertical-orange.svg b/res/skins/Deere/handle-vertical-orange.svg
+index 1b6b91152df..10f79b79b87 100644
+--- a/res/skins/Deere/handle-vertical-orange.svg
++++ b/res/skins/Deere/handle-vertical-orange.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="200" height="75" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="rotate(-90)" x="-70" y="5" width="65" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#e3ca1f"/><rect id="rect5888" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#ffb108"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="15" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m1 12v-9c0-1.108 0.892-2 2-2h34c1.108 0 2 0.892 2 2v9c0 1.108-0.892 2-2 2h-34c-1.108 0-2-0.892-2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m35.589 11h-31.178c-0.22768 0-0.41097-0.21148-0.41097-0.47417v-6.0517c0-0.26269 0.18329-0.47417 0.41097-0.47417h31.178c0.22768 0 0.41097 0.21148 0.41097 0.47417v6.0517c0 0.26269-0.18329 0.47417-0.41097 0.47417z" fill="#ffb108"/>
++</svg>
+diff --git a/res/skins/Deere/handle-vertical-purple.svg b/res/skins/Deere/handle-vertical-purple.svg
+index c606eac9b8c..1ccd440a239 100644
+--- a/res/skins/Deere/handle-vertical-purple.svg
++++ b/res/skins/Deere/handle-vertical-purple.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="200" height="75" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4138" transform="rotate(-90)" x="-70" y="5" width="65" height="190" rx="10" ry="10" fill="#333" stroke="#e0e0e0" stroke-width="10"/><rect id="rect4151-3" transform="scale(-1)" x="-177.87" y="-52.263" width="155.73" height="29.525" rx="2" ry="2" fill="#f2d440"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="15" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <path d="m1 12v-9c0-1.108 0.892-2 2-2h34c1.108 0 2 0.892 2 2v9c0 1.108-0.892 2-2 2h-34c-1.108 0-2-0.892-2-2z" fill="#333" stroke="#e0e0e0" stroke-width="2"/>
++ <path d="m35.589 11h-31.178c-0.22768 0-0.41097-0.21148-0.41097-0.47417v-6.0517c0-0.26269 0.18329-0.47417 0.41097-0.47417h31.178c0.22768 0 0.41097 0.21148 0.41097 0.47417v6.0517c0 0.26269-0.18329 0.47417-0.41097 0.47417z" fill="#f2d440"/>
++</svg>
+diff --git a/res/skins/Deere/slider-crossfader-AutoDJ.svg b/res/skins/Deere/slider-crossfader-AutoDJ.svg
+index 3d4ee50b5a6..281dd06c32a 100644
+--- a/res/skins/Deere/slider-crossfader-AutoDJ.svg
++++ b/res/skins/Deere/slider-crossfader-AutoDJ.svg
+@@ -1 +1,5 @@
+-<svg id="svg2" width="180" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect2984" x="3.9767" y="12.759" width="172.05" height="14.483" color="#000000" fill="#f60"/><!-- marker lines every 5px --><!-- end marker --><!-- quarter marker --><!-- middle marker --><!-- quarter marker --><!-- end marker --></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="180" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <rect x="1" y="12" width="178" height="16" color="#000000" fill="#f60"/>
++</svg>
+diff --git a/res/skins/Deere/slider-crossfader.svg b/res/skins/Deere/slider-crossfader.svg
+index 3ff945454de..ac5cb8cb52b 100644
+--- a/res/skins/Deere/slider-crossfader.svg
++++ b/res/skins/Deere/slider-crossfader.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="180" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4167" transform="rotate(90)" x="12.633" y="-176.2" width="14.734" height="172.4" rx=".92518" ry="1.0809" fill="none" stroke="#555" stroke-linecap="round" stroke-width="1.5"/><path id="path4175" d="m170.32 18.062h-160.64v3.875h160.64v-3.875z" fill="#222" stroke="#222" stroke-linecap="round" stroke-width="2.5"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="180" height="40" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <rect x="1.75" y="12.75" width="176.5" height="14.5" rx="1" ry="1" fill="none" stroke="#555" stroke-linecap="round" stroke-width="1.5"/>
++ <path d="m6.4826 20h167.03z" fill="none" stroke="#222" stroke-width="6"/>
++</svg>
+diff --git a/res/skins/Deere/slider-vertical.svg b/res/skins/Deere/slider-vertical.svg
+index 6876b84e028..30bc5061623 100644
+--- a/res/skins/Deere/slider-vertical.svg
++++ b/res/skins/Deere/slider-vertical.svg
+@@ -1,2 +1,6 @@
+-<!-- Created with Inkscape (http://www.inkscape.org/) -->
+-<svg id="svg2" width="40" height="162" version="1.1" xmlns="http://www.w3.org/2000/svg"><rect id="rect4167" x="12.633" y="1.25" width="14.734" height="159.5" rx="1" ry="1" fill="none" stroke="#555" stroke-linecap="round" stroke-width="1.5"/><path id="path4175" transform="translate(0,-9)" d="m18.062 15.688v148.62h3.875v-148.62h-3.875z" fill="#222" stroke="#222" stroke-linecap="round" stroke-width="2.5"/></svg>
++<?xml version="1.0" encoding="UTF-8"?>
++<svg width="40" height="162" version="1.1" xmlns="http://www.w3.org/2000/svg">
++ <style/>
++ <rect x="12.75" y="1.75" width="14.5" height="158.5" rx="1" ry="1" fill="none" stroke="#555" stroke-linecap="round" stroke-width="1.5"/>
++ <path d="m20 156v-150z" fill="none" stroke="#222" stroke-width="6"/>
++</svg>
+
+From 8d1e0e2aabb8c95c0ca06faa93d50dbc75f537db Mon Sep 17 00:00:00 2001
+From: "S.Brandt" <s.brandt@mixxx.org>
+Date: Fri, 17 Jan 2020 13:05:25 +0100
+Subject: [PATCH 2/2] Deere skin: Add maximum size for the crossfader slider
+ image to stop the crossfader handle from overflowing the background graphic.
+
+---
+ res/skins/Deere/mixer.xml | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/res/skins/Deere/mixer.xml b/res/skins/Deere/mixer.xml
+index b27e3e8b4e0..315d1f30709 100644
+--- a/res/skins/Deere/mixer.xml
++++ b/res/skins/Deere/mixer.xml
+@@ -122,6 +122,7 @@
+ <SliderComposed>
+ <TooltipId>crossfader</TooltipId>
+ <Size>1me,40f</Size>
++ <MaximumSize>200,40</MaximumSize>
+ <Slider scalemode="STRETCH">slider-crossfader.svg</Slider>
+ <Handle scalemode="STRETCH_ASPECT">handle-crossfader-orange.svg</Handle>
+ <Horizontal>true</Horizontal>
diff --git a/media-sound/mixxx/mixxx-2.2.3-r1.ebuild b/media-sound/mixxx/mixxx-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..d6c94204c6fd
--- /dev/null
+++ b/media-sound/mixxx/mixxx-2.2.3-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic scons-utils toolchain-funcs
+
+DESCRIPTION="Advanced Digital DJ tool based on Qt"
+HOMEPAGE="https://www.mixxx.org/"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mixxxdj/${PN}.git"
+else
+ #SRC_URI="https://downloads.mixxx.org/${P}/${P}-src.tar.gz"
+ SRC_URI="https://github.com/mixxxdj/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-release-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="aac doc ffmpeg hid lv2 mp3 mp4 opus shout wavpack"
+
+# fails to compile system-fidlib. Add ">media-libs/fidlib-0.9.10-r1" once this
+# got fixed
+RDEPEND="
+ dev-db/sqlite
+ dev-libs/glib:2
+ dev-libs/protobuf:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtscript:5[scripttools]
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ media-libs/chromaprint
+ media-libs/flac
+ media-libs/libid3tag
+ media-libs/libogg
+ media-libs/libsndfile
+ >=media-libs/libsoundtouch-1.5
+ media-libs/libvorbis
+ >=media-libs/portaudio-19_pre
+ media-libs/portmidi
+ media-libs/rubberband
+ media-libs/taglib
+ media-libs/vamp-plugin-sdk
+ sci-libs/fftw:3.0=
+ sys-power/upower
+ virtual/libusb:1
+ virtual/opengl
+ x11-libs/libX11
+ aac? (
+ media-libs/faad2
+ media-libs/libmp4v2:0
+ )
+ hid? ( dev-libs/hidapi )
+ lv2? ( >=media-libs/lilv-0.24.2-r3 )
+ mp3? ( media-libs/libmad )
+ mp4? ( media-libs/libmp4v2:= )
+ opus? ( media-libs/opusfile )
+ shout? ( media-libs/libshout )
+ wavpack? ( media-sound/wavpack )
+ ffmpeg? ( media-video/ffmpeg:0= )
+"
+# media-libs/rubberband RDEPENDs on sci-libs/fftw:3.0
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-qt/qttest:5
+ dev-qt/qtxmlpatterns:5
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.0-docs.patch
+ "${FILESDIR}"/${PN}-2.2.0-lilv_include_fix.patch
+ "${FILESDIR}"/${P}-qt-5.14.patch
+)
+
+src_prepare() {
+ # use multilib compatible directory for plugins
+ sed -i -e "/unix_lib_path =/s/'lib'/'$(get_libdir)'/" src/SConscript || die
+
+ default
+}
+
+src_configure() {
+ local myoptimize=0
+
+ # Required for >=qt-5.7.0 (bug #590690)
+ append-cxxflags -std=c++11
+
+ # Try to get cpu type based on CFLAGS.
+ # Bug #591968
+ for i in $(get-flag mcpu) $(get-flag march) ; do
+ if [[ ${i} = native ]] ; then
+ myoptimize="native"
+ break
+ fi
+ done
+
+ myesconsargs=(
+ prefix="${EPREFIX}/usr"
+ qtdir="${EPREFIX}/usr/$(get_libdir)/qt5"
+ faad="$(usex aac 1 0)"
+ ffmpeg="$(usex ffmpeg 1 0)"
+ hid="$(usex hid 1 0)"
+ hifieq=1
+ lilv="$(usex lv2 1 0)"
+ m4a="$(usex mp4 1 0)"
+ mad="$(usex mp3 1 0)"
+ optimize="${myoptimize}"
+ opus="$(usex opus 1 0)"
+ qt5=1
+ shoutcast="$(usex shout 1 0)"
+ vinylcontrol=1
+ wv="$(usex wavpack 1 0)"
+ )
+}
+
+src_compile() {
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINKFLAGS="${LDFLAGS}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" escons ${myesconsargs[@]}
+}
+
+src_install() {
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINKFLAGS="${LDFLAGS}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" escons ${myesconsargs[@]} \
+ install_root="${ED%/}"/usr install
+
+ dodoc README Mixxx-Manual.pdf
+}