summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-08-23 21:59:24 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-08-23 22:00:53 +0200
commit7d7c598b68c92419964e23d4ffa8c51a8c3eba62 (patch)
tree84c9f1a1fb36ec6eac695a4b4656754bdcd759a1 /media-sound/patchage
parentdev-python/ensurepip-setuptools: add 65.2.0 (diff)
downloadgentoo-7d7c598b68c92419964e23d4ffa8c51a8c3eba62.tar.gz
gentoo-7d7c598b68c92419964e23d4ffa8c51a8c3eba62.tar.bz2
gentoo-7d7c598b68c92419964e23d4ffa8c51a8c3eba62.zip
media-sound/patchage: bump to 1.0.8 + added live
Closes: https://bugs.gentoo.org/865437 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/patchage')
-rw-r--r--media-sound/patchage/Manifest1
-rw-r--r--media-sound/patchage/patchage-1.0.8.ebuild50
-rw-r--r--media-sound/patchage/patchage-9999.ebuild50
3 files changed, 101 insertions, 0 deletions
diff --git a/media-sound/patchage/Manifest b/media-sound/patchage/Manifest
index 8fca8a198910..6b8aee71b9f9 100644
--- a/media-sound/patchage/Manifest
+++ b/media-sound/patchage/Manifest
@@ -1 +1,2 @@
DIST patchage-1.0.6.tar.bz2 664841 BLAKE2B 72d0de6d12e07ec160f4c59c51f138e1220a1b8994bdab90f56dd715bf16b6f561836d184ec5d5077de3bc7bb5c6778ea2b7bcbf0b33230be662f2b729eac568 SHA512 b7aedcb07da0c81842929833ab93a0b20c08e465bf05ebb4e47670d295c0d4d0d50f0f74001d9264c2c23ef08d3881232e7622ecf101d1d53ffcae2f8c0f31d3
+DIST patchage-1.0.8.tar.xz 334888 BLAKE2B d6bac04a3a6880c7758a01c60b4f4c907e7ae191ef8956fb6ad6f039d9bf40e973ff6e38fc6a5af5b4b4ce5386496282ab5cb06573b0e091e24b7c80fae73ac3 SHA512 af2e43c53ce80ab59416745e85cd7fc524fd3b21ae259d171f15998566cfa067a84a7406e78f5b50bc3ff339363b3ed9cacc9790f08cc6189e4919fc43d041dc
diff --git a/media-sound/patchage/patchage-1.0.8.ebuild b/media-sound/patchage/patchage-1.0.8.ebuild
new file mode 100644
index 000000000000..a629310e40dd
--- /dev/null
+++ b/media-sound/patchage/patchage-1.0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
+HOMEPAGE="https://drobilla.net/software/patchage"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/drobilla/patchage.git"
+else
+ SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa jack jack-dbus test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ media-libs/ganv
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ jack-dbus? (
+ dev-libs/dbus-glib
+ sys-apps/dbus
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/libfmt:="
+
+DOCS=( AUTHORS NEWS README.md )
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature alsa)
+ $(meson_feature jack)
+ $(meson_feature jack-dbus jack_dbus)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
diff --git a/media-sound/patchage/patchage-9999.ebuild b/media-sound/patchage/patchage-9999.ebuild
new file mode 100644
index 000000000000..e449d00c7bf0
--- /dev/null
+++ b/media-sound/patchage/patchage-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
+HOMEPAGE="https://drobilla.net/software/patchage"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/drobilla/patchage.git"
+else
+ SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa jack jack-dbus test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ media-libs/ganv
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ jack-dbus? (
+ dev-libs/dbus-glib
+ sys-apps/dbus
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ >=dev-libs/libfmt-9:="
+
+DOCS=( AUTHORS NEWS README.md )
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature alsa)
+ $(meson_feature jack)
+ $(meson_feature jack-dbus jack_dbus)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}