summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ptabtools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ptabtools/files')
-rw-r--r--media-sound/ptabtools/files/ptabtools-0.5.0-makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/ptabtools/files/ptabtools-0.5.0-makefile.patch b/media-sound/ptabtools/files/ptabtools-0.5.0-makefile.patch
new file mode 100644
index 000000000000..72c72a58599b
--- /dev/null
+++ b/media-sound/ptabtools/files/ptabtools-0.5.0-makefile.patch
@@ -0,0 +1,27 @@
+--- ptabtools-0.5.0/Makefile.orig
++++ ptabtools-0.5.0/Makefile
+@@ -8,13 +8,13 @@
+ all: $(TARGETS)
+
+ tests/check: tests/check.o tests/ptb.o tests/gp.o ptb.o
+- $(CC) $(FLAGS) $^ -o $@ $(CHECK_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ $(CHECK_LIBS)
+
+ ptb2xml.o: ptb2xml.c
+ $(CC) $(CFLAGS) -c $< $(LIBXSLT_CFLAGS) $(LIBXML_CFLAGS) $(XSLT_DEFINE)
+
+ %.o: %.c
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -I. -c $< -o $@
+
+ %.po: %.c
+ $(CC) $(CFLAGS) -fPIC -c $< -o $@
+@@ -23,7 +23,7 @@
+ $(CC) $(SHFLAGS) $(CFLAGS) -Wl,--out-implib=ptb.dll.a -o $@ $^
+
+ libptb.so.$(VERSION): $(PTBLIB_OBJS:.o=.po)
+- $(CC) $(SHFLAGS) -Wl,-soname,libptb.so.$(SOVERSION) -Wl,$@ $(CFLAGS) -o $@ $^
++ $(CC) $(SHFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ libptb.a: $(PTBLIB_OBJS)
+ $(AR) rs $@ $^