summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-21 13:08:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-21 13:08:46 +0200
commit7e57bf3a902a03e850534c6f3ce090ce8ed5c482 (patch)
tree2fb5283fba6de0b788569f2b847e0d3f5548bdee /media-sound/pulseaudio
parentdev-python/gast: Fix variable ordering (diff)
downloadgentoo-7e57bf3a902a03e850534c6f3ce090ce8ed5c482.tar.gz
gentoo-7e57bf3a902a03e850534c6f3ce090ce8ed5c482.tar.bz2
gentoo-7e57bf3a902a03e850534c6f3ce090ce8ed5c482.zip
media-sound/pulseaudio: minor fixes
- Update GIO build patch to what got merged. - Add bluez build batch. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch21
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch89
-rw-r--r--media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild7
3 files changed, 112 insertions, 5 deletions
diff --git a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
index dfce24881566..a6554178da60 100644
--- a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
+++ b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
@@ -1,11 +1,13 @@
-From fe25df45d5742f20a225e9d9cd790156a7f05943 Mon Sep 17 00:00:00 2001
+From 58052e0e04ee1b5fdb1027ebc19717e7766825ec Mon Sep 17 00:00:00 2001
From: "Igor V. Kovalenko" <igor.v.kovalenko@gmail.com>
Date: Mon, 21 Jun 2021 02:32:41 +0300
Subject: [PATCH] build-sys: meson: require GIO dependency for RTP-GStreamer
+Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/584>
---
- meson.build | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
+ meson.build | 6 ++++--
+ src/modules/meson.build | 2 +-
+ 2 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
index fdd8bf655..61660b981 100644
@@ -31,6 +33,19 @@ index fdd8bf655..61660b981 100644
have_gstreamer = true
endif
+diff --git a/src/modules/meson.build b/src/modules/meson.build
+index 9c498a4e1..e7db573b6 100644
+--- a/src/modules/meson.build
++++ b/src/modules/meson.build
+@@ -161,7 +161,7 @@ if dbus_dep.found() and fftw_dep.found()
+ ]
+ endif
+
+-if gio_dep.found()
++if get_option('gsettings').enabled() and gio_dep.found()
+ subdir('gsettings')
+ all_modules += [
+ [ 'module-gsettings',
--
GitLab
diff --git a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch
new file mode 100644
index 000000000000..5983a05ea4a9
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch
@@ -0,0 +1,89 @@
+From c817dfb5a438055c98449a4a2f34eb4ec341ccde Mon Sep 17 00:00:00 2001
+From: "Igor V. Kovalenko" <igor.v.kovalenko@gmail.com>
+Date: Fri, 18 Jun 2021 20:48:12 +0300
+Subject: [PATCH] build-sys: meson: Require bluez dependency if bluez5 feature
+ is enabled
+
+Build breaks if bluez5 and bluez5-native-headset are both enabled
+but bluez headers are not available.
+
+Fix this by changing `bluez5` to Meson feature requiring `bluez` dependency.
+
+Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/583>
+---
+ meson.build | 10 ++++++----
+ meson_options.txt | 2 +-
+ src/modules/bluetooth/meson.build | 2 +-
+ src/modules/meson.build | 2 +-
+ 4 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 61660b981..92ceef706 100644
+--- a/meson.build
++++ b/meson.build
+@@ -706,7 +706,9 @@ endif
+
+ sbc_dep = dependency('sbc', version : '>= 1.0', required : false)
+
+-if get_option('bluez5')
++bluez_dep = dependency('bluez', required : get_option('bluez5'))
++
++if bluez_dep.found()
+ assert(dbus_dep.found(), 'BlueZ requires D-Bus support')
+ assert(sbc_dep.found(), 'BlueZ requires SBC support')
+ cdata.set('HAVE_SBC', 1)
+@@ -914,9 +916,9 @@ summary = [
+ 'Enable Async DNS: @0@'.format(asyncns_dep.found()),
+ 'Enable LIRC: @0@'.format(lirc_dep.found()),
+ 'Enable D-Bus: @0@'.format(dbus_dep.found()),
+- ' Enable BlueZ 5: @0@'.format(get_option('bluez5')),
+- ' Enable native headsets: @0@'.format(get_option('bluez5-native-headset')),
+- ' Enable ofono headsets: @0@'.format(get_option('bluez5-ofono-headset')),
++ ' Enable BlueZ 5: @0@'.format(cdata.has('HAVE_BLUEZ_5')),
++ ' Enable native headsets: @0@'.format(cdata.has('HAVE_BLUEZ_5_NATIVE_HEADSET')),
++ ' Enable ofono headsets: @0@'.format(cdata.has('HAVE_BLUEZ_5_OFONO_HEADSET')),
+ ' Enable GStreamer based codecs: @0@'.format(have_bluez5_gstreamer),
+ 'Enable udev: @0@'.format(udev_dep.found()),
+ ' Enable HAL->udev compat: @0@'.format(get_option('hal-compat')),
+diff --git a/meson_options.txt b/meson_options.txt
+index cdb3c6787..bb41a42a7 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -85,7 +85,7 @@ option('avahi',
+ type : 'feature', value : 'auto',
+ description : 'Optional Avahi support')
+ option('bluez5',
+- type : 'boolean', value : 'true',
++ type : 'feature', value : 'auto',
+ description : 'Optional BlueZ 5 support')
+ option('bluez5-gstreamer',
+ type : 'feature', value: 'auto',
+diff --git a/src/modules/bluetooth/meson.build b/src/modules/bluetooth/meson.build
+index 99263bb5a..ca77ee6aa 100644
+--- a/src/modules/bluetooth/meson.build
++++ b/src/modules/bluetooth/meson.build
+@@ -35,7 +35,7 @@ libbluez5_util = shared_library('bluez5-util',
+ c_args : [pa_c_args, server_c_args],
+ link_args : [nodelete_link_args],
+ include_directories : [configinc, topinc],
+- dependencies : [libpulse_dep, libpulsecommon_dep, libpulsecore_dep, dbus_dep, sbc_dep, libintl_dep, bluez5_gst_dep, bluez5_gstapp_dep],
++ dependencies : [libpulse_dep, libpulsecommon_dep, libpulsecore_dep, bluez_dep, dbus_dep, sbc_dep, libintl_dep, bluez5_gst_dep, bluez5_gstapp_dep],
+ install : true,
+ install_rpath : privlibdir,
+ install_dir : modlibexecdir,
+diff --git a/src/modules/meson.build b/src/modules/meson.build
+index e7db573b6..be72c3b9b 100644
+--- a/src/modules/meson.build
++++ b/src/modules/meson.build
+@@ -118,7 +118,7 @@ if avahi_dep.found()
+ ]
+ endif
+
+-if get_option('bluez5')
++if cdata.has('HAVE_BLUEZ_5')
+ subdir('bluetooth')
+ all_modules += [
+ [ 'module-bluetooth-discover', 'bluetooth/module-bluetooth-discover.c' ],
+--
+GitLab
+
diff --git a/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild b/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild
index 203ebb43b879..5e4d232b4c41 100644
--- a/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild
@@ -164,7 +164,10 @@ DOCS=( NEWS README )
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${MY_P}-require-GIO-for-RTP-GStreamer.patch )
+PATCHES=(
+ "${FILESDIR}"/${MY_P}-require-GIO-for-RTP-GStreamer.patch
+ "${FILESDIR}"/${MY_P}-require-bluez-dependency.patch
+)
src_prepare() {
default
@@ -181,7 +184,7 @@ multilib_src_configure() {
-Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
-Dbashcompletiondir="$(get_bashcompdir)" # Alternatively DEPEND on app-shells/bash-completion for pkg-config to provide the value
$(meson_native_use_feature alsa)
- $(meson_native_use_bool bluetooth bluez5)
+ $(meson_native_use_feature bluetooth bluez5)
$(meson_native_use_bool daemon)
$(meson_native_use_bool doc doxygen)
$(meson_native_use_bool native-headset bluez5-native-headset)