summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-01-27 09:42:55 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-27 09:42:55 +0100
commit4dbf4f80da2ee7c5e3325d4f25512dc0ed1a4b48 (patch)
treec2ef32be1c49125d7921d199fbb0f75cfc63f9b4 /media-sound/zynaddsubfx
parentmedia-libs/rubberband: bump to 2.0.2, dropped 2.0.1 (diff)
downloadgentoo-4dbf4f80da2ee7c5e3325d4f25512dc0ed1a4b48.tar.gz
gentoo-4dbf4f80da2ee7c5e3325d4f25512dc0ed1a4b48.tar.bz2
gentoo-4dbf4f80da2ee7c5e3325d4f25512dc0ed1a4b48.zip
media-sound/zynaddsubfx: bump to 3.0.6, +alsa
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/zynaddsubfx')
-rw-r--r--media-sound/zynaddsubfx/Manifest1
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-docs.patch14
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-3.0.6.ebuild89
3 files changed, 104 insertions, 0 deletions
diff --git a/media-sound/zynaddsubfx/Manifest b/media-sound/zynaddsubfx/Manifest
index 57b7d0923fc5..64dfea5bacae 100644
--- a/media-sound/zynaddsubfx/Manifest
+++ b/media-sound/zynaddsubfx/Manifest
@@ -1 +1,2 @@
DIST zynaddsubfx-3.0.5.tar.bz2 8141703 BLAKE2B 61f28a62d5ef8c17b5e38febb8ad1ecd40c80f87b26d90804131b97b57534adf5ad96a1f54980b75fd5e71185e2d5376a7df35696c7bcfd593b5d8e34bd2e386 SHA512 1e4d5a6393937e6c7103e6d0e97df76f2d129350854c2f338aa888591091b1508c63e9b52c8e5a176e282ff2f6b72c6a87de54875c412771aff26e8ece2c84e8
+DIST zynaddsubfx-3.0.6.tar.bz2 10001014 BLAKE2B 4adbeffb9bc0bd77bf81a6734f5c26fc676426e644e27cebb8e54e8d74d869c0e1b468782cd1a64aacef8f9b788d434a8d30a194944650eea03c4fd146ee7bf7 SHA512 86311f00d97e20c7eb22a46c99736c56765ed9737e728ef380a324e4a92c731086ed74f5d7bfeae104b690ab1ee1b40bfb8f240bc4c46f8afd47308ec48cbcea
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-docs.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-docs.patch
new file mode 100644
index 000000000000..e10b92d096eb
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-docs.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5c70857..20e20d2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,9 +35,6 @@ include(CTestConfig.cmake)
+ add_subdirectory(src)
+ add_subdirectory(doc) # Doxygen only
+
+-install(FILES AUTHORS.txt COPYING README.adoc
+- DESTINATION share/doc/zynaddsubfx
+- )
+ install(FILES zynaddsubfx-jack-multi.desktop zynaddsubfx-jack.desktop zynaddsubfx-alsa.desktop zynaddsubfx-oss.desktop
+ DESTINATION share/applications)
+ install(FILES zynaddsubfx.svg
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-3.0.6.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-3.0.6.ebuild
new file mode 100644
index 000000000000..7ba88ec4ec0a
--- /dev/null
+++ b/media-sound/zynaddsubfx/zynaddsubfx-3.0.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Software synthesizer capable of making a countless number of instruments"
+HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zynaddsubfx/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+alsa doc dssi +fltk jack lash portaudio"
+
+REQUIRED_USE="|| ( alsa jack portaudio )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/mxml
+ media-libs/liblo
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ dssi? ( media-libs/dssi )
+ fltk? (
+ x11-libs/fltk:1
+ x11-libs/libX11
+ x11-libs/libXpm
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docs.patch
+)
+
+DOCS=( AUTHORS.txt NEWS.txt README.adoc )
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use dssi; then
+ sed -i -e '/pkg_search_module.*DSSI/s/^/#DONT/' src/CMakeLists.txt || die
+ fi
+ if ! use jack; then
+ sed -e '/pkg_check_modules.*JACK/s/^/#DONT/' -i {rtosc,src}/CMakeLists.txt || die
+ fi
+ if ! use lash; then
+ sed -i -e '/pkg_search_module.*LASH/s/^/#DONT/' src/CMakeLists.txt || die
+ fi
+ if ! use portaudio; then
+ sed -i -e '/pkg_check_modules.*PORTAUDIO/s/^/#DONT/' src/CMakeLists.txt || die
+ fi
+
+ # FIXME upstream: sandbox error
+ sed -i -e '/add_subdirectory(bash-completion)/d' doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DPluginLibDir=$(get_libdir)
+ $(cmake_use_find_package alsa Alsa)
+ $(cmake_use_find_package doc Doxygen)
+ $(cmake_use_find_package fltk FLTK)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+ insinto /usr/share/${PN}
+ doins -r instruments/*
+}