summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-20 07:12:06 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-20 07:12:06 +0200
commitfe9c51dbe7a455710212142974b018589c190352 (patch)
treec9d57855b1fa24d7ac31f69818bc98a36b67fa4d /media-sound
parentdev-lang/php: Recent mysqlnd driver needs hash extension (diff)
downloadgentoo-fe9c51dbe7a455710212142974b018589c190352.tar.gz
gentoo-fe9c51dbe7a455710212142974b018589c190352.tar.bz2
gentoo-fe9c51dbe7a455710212142974b018589c190352.zip
media-sound/ncmpc: Set -Dcolors=true
While there, fix whitespace. Fixes: https://bugs.gentoo.org/666566 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ncmpc/ncmpc-0.31.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/media-sound/ncmpc/ncmpc-0.31.ebuild b/media-sound/ncmpc/ncmpc-0.31.ebuild
index 737d9ce04b02..0240eb2006df 100644
--- a/media-sound/ncmpc/ncmpc-0.31.ebuild
+++ b/media-sound/ncmpc/ncmpc-0.31.ebuild
@@ -14,15 +14,21 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="+artist-screen async-connect chat-screen doc +help-screen key-screen lirc lyrics-screen outputs-screen search-screen +song-screen +mouse nls tcp"
-RDEPEND="dev-libs/glib:2
- media-libs/libmpdclient
- sys-libs/ncurses:0=[unicode]
- lirc? ( app-misc/lirc )"
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libmpdclient
+ sys-libs/ncurses:0=[unicode]
+ lirc? ( app-misc/lirc )
+"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx
- app-doc/doxygen )
- virtual/pkgconfig"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+ virtual/pkgconfig
+"
DOCS=( doc/. AUTHORS README.rst )
@@ -34,7 +40,7 @@ src_prepare() {
src_configure() {
local emesonargs=(
-Dcurses=ncursesw
- -Dcolors=ncursesw
+ -Dcolors=true
-Dmini=false
-Dlyrics_plugin_dir="${EPREFIX}/usr/$(get_libdir)/ncmpc/lyrics"
-Dartist_screen=$(usex artist-screen true false)