summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 18:32:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 18:33:30 +0100
commit8882d9ea7fb8c525659d8239db86c387d6915498 (patch)
tree34389a91db5e6366dffd355e3b672e10bf2b2604 /media-video/avidemux
parentdev-libs/leatherman: 1.4.4 stable amd64 and x86 with cleanup (diff)
downloadgentoo-8882d9ea7fb8c525659d8239db86c387d6915498.tar.gz
gentoo-8882d9ea7fb8c525659d8239db86c387d6915498.tar.bz2
gentoo-8882d9ea7fb8c525659d8239db86c387d6915498.zip
media-video/avidemux: Fix build with glibc-2.27
Reported-by: Helmut Jarausch <jarausch@igpm.rwth-aachen.de> Thanks-to: emerald <dirk@liji-und-dirk.de> Closes: https://bugs.gentoo.org/646494 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/avidemux')
-rw-r--r--media-video/avidemux/avidemux-2.7.0.ebuild4
-rw-r--r--media-video/avidemux/avidemux-9999.ebuild4
-rw-r--r--media-video/avidemux/files/avidemux-2.7.0-glibc-2.27.patch22
3 files changed, 25 insertions, 5 deletions
diff --git a/media-video/avidemux/avidemux-2.7.0.ebuild b/media-video/avidemux/avidemux-2.7.0.ebuild
index 3408af19d4a3..3a3537441542 100644
--- a/media-video/avidemux/avidemux-2.7.0.ebuild
+++ b/media-video/avidemux/avidemux-2.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -46,7 +46,7 @@ PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt5?]"
S="${WORKDIR}/${MY_P}"
src_prepare() {
- default
+ eapply "${FILESDIR}/${P}-glibc-2.27.patch"
processes="buildCli:avidemux/cli"
if use qt5 ; then
diff --git a/media-video/avidemux/avidemux-9999.ebuild b/media-video/avidemux/avidemux-9999.ebuild
index 3408af19d4a3..6d44aea9bcd2 100644
--- a/media-video/avidemux/avidemux-9999.ebuild
+++ b/media-video/avidemux/avidemux-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -46,8 +46,6 @@ PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt5?]"
S="${WORKDIR}/${MY_P}"
src_prepare() {
- default
-
processes="buildCli:avidemux/cli"
if use qt5 ; then
processes+=" buildQt4:avidemux/qt4"
diff --git a/media-video/avidemux/files/avidemux-2.7.0-glibc-2.27.patch b/media-video/avidemux/files/avidemux-2.7.0-glibc-2.27.patch
new file mode 100644
index 000000000000..166791f4774a
--- /dev/null
+++ b/media-video/avidemux/files/avidemux-2.7.0-glibc-2.27.patch
@@ -0,0 +1,22 @@
+From afdd9c4b876d77a4974d3fa7d9f25caeffbdf13d Mon Sep 17 00:00:00 2001
+From: eumagga0x2a <eumagga0x2a@users.noreply.github.com>
+Date: Fri, 29 Sep 2017 15:53:14 +0200
+Subject: [PATCH] [build] Fix compilation with glibc >= 2.27
+
+---
+ avidemux/common/ADM_audioFilter/src/audiofilter_normalize.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/avidemux/common/ADM_audioFilter/src/audiofilter_normalize.cpp b/avidemux/common/ADM_audioFilter/src/audiofilter_normalize.cpp
+index c6cb43bb6..269c2d2e3 100644
+--- a/avidemux/common/ADM_audioFilter/src/audiofilter_normalize.cpp
++++ b/avidemux/common/ADM_audioFilter/src/audiofilter_normalize.cpp
+@@ -35,7 +35,7 @@
+ #elif defined(ADM_BSD_FAMILY) || defined(__sun__)
+ #define POW10(x) powf(10.0,x)
+ #else
+-#define POW10(x) pow10f(x)
++#define POW10(x) exp10f(x)
+ #endif
+
+ #define LINEAR_TO_DB(x) (20.*log10(x))