summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-03 06:38:03 +0000
committerSam James <sam@gentoo.org>2024-01-03 06:38:03 +0000
commitdba143d2e7f2485076b975290c8cff16202a5f6d (patch)
treeda0214633c3e70f012baa7a77d5ec42fd7d5cd09 /media-video/ffmpeg
parentmedia-video/ffmpeg: backport texinfo fixes to 4.4 (diff)
downloadgentoo-dba143d2e7f2485076b975290c8cff16202a5f6d.tar.gz
gentoo-dba143d2e7f2485076b975290c8cff16202a5f6d.tar.bz2
gentoo-dba143d2e7f2485076b975290c8cff16202a5f6d.zip
media-video/ffmpeg: enable USE=pic by default
binutils-2.41 is configured in Gentoo to reject textrels by default which the non-PIC-safe x86 (32-bit) asm requires. Start by defaulting USE=pic to on in general but we can remove the USE flag later and then just pass --disable-asm for 32-bit x86. Bug: https://bugs.gentoo.org/916067 Bug: https://bugs.gentoo.org/920808 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-5.1.4-r1.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-6.0-r10.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-6.0-r9.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-6.0.1.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1-r3.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1.1.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild4
8 files changed, 14 insertions, 14 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild b/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild
index b688a1857b4e..dd95ea498d94 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-5.1.4-r1.ebuild b/media-video/ffmpeg/ffmpeg-5.1.4-r1.ebuild
index 39d9265358be..e10f598a6997 100644
--- a/media-video/ffmpeg/ffmpeg-5.1.4-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-5.1.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-6.0-r10.ebuild b/media-video/ffmpeg/ffmpeg-6.0-r10.ebuild
index 635fcf2e4f7d..74a648a4cc18 100644
--- a/media-video/ffmpeg/ffmpeg-6.0-r10.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.0-r10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-6.0-r9.ebuild b/media-video/ffmpeg/ffmpeg-6.0-r9.ebuild
index a494461a30e2..2454bd54cad6 100644
--- a/media-video/ffmpeg/ffmpeg-6.0-r9.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.0-r9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-6.0.1.ebuild b/media-video/ffmpeg/ffmpeg-6.0.1.ebuild
index 7a382e4aeebd..6b9dc10b5bf6 100644
--- a/media-video/ffmpeg/ffmpeg-6.0.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-6.1-r3.ebuild b/media-video/ffmpeg/ffmpeg-6.1-r3.ebuild
index b79bccb0a98f..482524b3d718 100644
--- a/media-video/ffmpeg/ffmpeg-6.1-r3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-6.1.1.ebuild b/media-video/ffmpeg/ffmpeg-6.1.1.ebuild
index 36572f204937..aa526685a188 100644
--- a/media-video/ffmpeg/ffmpeg-6.1.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1.1.ebuild
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 188eb6e7b762..8f10926eaca6 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,7 +108,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa chromium doc +encode oss pic sndio static-libs test v4l
+ alsa chromium doc +encode oss +pic sndio static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"