summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-06-11 09:59:11 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-06-11 10:38:44 +0300
commit93d6acc9137a65d6aabd346a6f6d2dbac0d94fbd (patch)
tree5b091e0cf00dbbdcba4bab580ed7a873e487550d /media-video/yle-dl
parentapp-accessibility/espeak-ng: arm64 stable wrt bug #850919 (diff)
downloadgentoo-93d6acc9137a65d6aabd346a6f6d2dbac0d94fbd.tar.gz
gentoo-93d6acc9137a65d6aabd346a6f6d2dbac0d94fbd.tar.bz2
gentoo-93d6acc9137a65d6aabd346a6f6d2dbac0d94fbd.zip
media-video/yle-dl: add 20220610
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest1
-rw-r--r--media-video/yle-dl/yle-dl-20220610.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index d4d9107e320c..0da0881c4fee 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1 +1,2 @@
DIST yle-dl-20220531.tar.gz 68985 BLAKE2B 66a011a741089aeb5a1247d9d4571341b0584b859831460c1ed39db8df0c0838e5271b5d5d9004f6c62134235cd881bc6a24752ef1a88ace95158b00803d5c13 SHA512 499929a8411c515259890fd228970718a357a19b221605cd882d9baa0c8ac688241a4cf8eeb2e75dbc26c28536579db1a5c0ae9db29fb4796b2ca1e093a8de36
+DIST yle-dl-20220610.tar.gz 69065 BLAKE2B 6b61351b23d1ea3f351a237bcf31aa9f542e15e621f88350f4758a97016631713b0a4e45c3878139e1040ab8dca671a91dff82c7f1c044de5493890ba0894d87 SHA512 87b8b5a63eb68f60a6b0de47c06ab3f6efd018767138f3da33fa51ecc4a8e56017fedfba20a190b451db3e862ce5a3abc7e9c7f485e9042e300913d47e8ed735
diff --git a/media-video/yle-dl/yle-dl-20220610.ebuild b/media-video/yle-dl/yle-dl-20220610.ebuild
new file mode 100644
index 000000000000..e2fb7c128ddc
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20220610.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="https://aajanki.github.io/yle-dl/ https://github.com/aajanki/yle-dl"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Requires an active internet connection during tests,
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="media-video/ffmpeg
+ net-misc/wget
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ ${RDEPEND}
+ media-video/ffmpeg[gnutls]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/yledl.conf.sample"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ elog "Sample configuration file has been installed to "
+ elog " /usr/share/doc/yle-dl-${PVR}/yledl.conf.sample"
+ elog
+ optfeature "youtube-dl download engine" net-misc/youtube-dl net-misc/yt-dlp
+}